3

Until yesterday my whole qgis and python-qgis worked fine with version 2.14 under Ubuntu 14.04. After a simple sudo apt-get update and sudo apt-get upgrade qgis failed to update... Several attempts to reinstall it with different versions failed.

Current error message (for version 2.14.3) goes like this:

qgis-providers (2.14.3+dfsg-2~trusty1) is configured ...
/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libgdal.so.20: undefined symbol: GEOSDelaunayTriangulation_r

I also tried to reinstall all gdal libraries - not sure if I got all?!

Maybe it is somehow related to this one: QGIS 2.14 fails to install on Ubuntu 14.04 ?

UPDATE:

Trying to install version 2.16.0 it gives different but similar error:

/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libqgis_core.so.2.16.0: undefined symbol: GEOSNearestPoints_r

UPDATE Sources:

For version 2.16.0 there are these sources in /etc/apt/sources.list:

deb http://qgis.org/debian trusty main
deb-src http://qgis.org/debian trusty main
deb http://qgis.org/debian trusty main
deb-src http://qgis.org/debian trusty main

which are all the same, right?

When I do apt-cache policy qgis it gives me:

qgis:
  Installiert:           1:2.16.0+20trusty
  Installationskandidat: 1:2.16.0+20trusty
  Versionstabelle:
 *** 1:2.16.0+20trusty 0
        500 http://qgis.org/debian/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     2.0.1-2build2 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

closed as off-topic by Henhuy, ArMoraer, PolyGeo Nov 14 '16 at 10:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Henhuy, ArMoraer, PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • which version of ubuntu are you running? – Ian Turton Jul 19 '16 at 10:50
  • I'm using Ubuntu 14.04 - just added it to the question. thx – Henhuy Jul 19 '16 at 10:57
  • What's your repository configuration? In other words, where is ubuntu trying to get qgis from? Look in /etc/apt/sources.list and sources.list.d/* – Spacedman Jul 19 '16 at 12:30
  • I also reported the bug on QGis Application System: hub.qgis.org/issues/15307 maybe they can help as well?! – Henhuy Jul 19 '16 at 13:30
  • I have the same problem here. I used the qgis version based on the launchpad.net/~ubuntugis/+archive/ubuntu/ubuntugis-unstable repository. Tried both qgis 2.14 and 2.16 to install on Ubuntu 14.04. – lukaskrieger Aug 10 '16 at 11:42
2

On my machine

 Linux astun-desktop 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

With the qgis.org repo set:

deb http://qgis.org/debian/ trusty main

The system update manager updated me to Qgis 2.16.0-Nødebo with no manual intervention from me at all.

  • I tried this to - see my update above – Henhuy Jul 19 '16 at 11:14
  • I've had two qgis 2.16 updates work fine on Linux Mint but the first one I just tried from Dell's stock Ubuntu broke qgis etc very badly (also installed a kernel with no networking support, but that's another story...). Problem with qgis seems to be libgdal2 related. – Spacedman Jul 19 '16 at 12:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.