1

I have python 2.7 and I have just installed (via pip) a module named 'dicttoxml'. This module should work with 2.6+ python version. I am importing it to my *.py file and using it in my plugin code. When I am lauching QGIS and trying to use my plugin, an error occures:

File "C:/PROGRA~1/QGISWI~1/apps/qgis-ltr/./python\qgis\utils.py", line 478, in _import mod = _builtin_import(name, globals, locals, fromlist, level) ImportError: No module named dicttoxml

Anyone can help?

  • Where have you installed the module, in a independent Python version or in the QGIS version of Python ? – gene Jul 19 '16 at 15:02
  • I just typed 'py -m pip install xmltodict' in my cmd console. I'm not sure if I done it right way. – W. Tom Jul 20 '16 at 6:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.