-2

enter image description hereUsing ArcGIS 10.4 for Desktop, I am trying to build a model to be published as a service. this model should take shapefile and table as inputs and run "Join Field" tool on them then i am using "feature class to feature class" tool to save that shapefile as a featureclass in a db. so far the service output is: Job Status: esriJobSucceeded

Results: None

attached the screenshot from my model the model works fine on arcmap and i can see the feature class created in the default db. i was expecting to do the same when i run as a service, when i checked the default db on the server, couldn't find the output

i m wondering why it didn't save anything in the db ? am i missing a step ?

  • What were all the steps that you performed from creating it to publishing and testing it as a geoprocessing service? – PolyGeo Jul 20 '16 at 11:42
  • created the model,saved it, closed, run as toolbox, got results in the results window, right click share as a service, enabled upload for rest service, once published i tried to call it using a GPFeatureRecordSerLayer json and submitted the job then got that results – user78248 Jul 20 '16 at 12:00
  • There's an edit button beneath your question that should be used to provide more details. To me it seems like your question is giving too little detail, especially regarding the model and its tools and parameters. – PolyGeo Jul 20 '16 at 12:05
1

It is a while since I have done this but it looks to me like your model may not have specified an output parameter.

If you compare your model to one in the Help page titled A quick tour of authoring and sharing geoprocessing services you will see that the latter has two input and one output parameters while yours only has a single input parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.