1

This question already has an answer here:

I format my notebook because this problem, but it wasn't solved. Any suggestion to fix it?

The following packages have unmet dependencies: python-qgis : Depends: python-qgis-common (= 1:2.14.4-1+20trusty-ubuntugis) but it is not going to be installed Depends: libqgispython2.14.4 but it is not going to be installed Depends: libqgis-analysis2.14.4 but it is not going to be installed Depends: libqgis-core2.14.4 but it is not going to be installed Depends: libqgis-gui2.14.4 but it is not going to be installed Depends: libqgis-networkanalysis2.14.4 but it is not going to be installed Depends: libqgis-server2.14.4 but it is not going to be installed qgis : Depends: gdal-abi-2-1-0 but it is not installable Depends: libgdal20 (>= 2.0.1) but it is not installable Depends: libgeos-c1v5 (>= 3.4.2) but it is not installable Depends: libqgis-analysis2.14.4 but it is not going to be installed Depends: libqgis-app2.14.4 but it is not going to be installed Depends: libqgis-core2.14.4 but it is not going to be installed Depends: libqgis-gui2.14.4 but it is not going to be installed Depends: libqgis-networkanalysis2.14.4 but it is not going to be installed Depends: qgis-providers (= 1:2.14.4-1+20trusty-ubuntugis) but it is not going to be installed Recommends: qgis-plugin-globe but it is not going to be installed Recommends: qgis-provider-grass but it is not going to be installed qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.4-1+20trusty-ubuntugis) but it is not going to be installed Depends: libgdal20 (>= 1.8.0) but it is not installable Depends: libqgis-app2.14.4 but it is not going to be installed Depends: libqgis-core2.14.4 but it is not going to be installed Depends: libqgis-gui2.14.4 but it is not going to be installed Depends: libqgisgrass7-2.14.4 but it is not going to be installed E: Unable to correct problems, you have held broken packages.

marked as duplicate by Ian Turton Jul 20 '16 at 14:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Can you edit your post and show how you produced these error messages, please? – karpfen Jul 20 '16 at 14:47
  • I changed my repository to qgis.org/debian-ltr and all worked well. – Diogo Caribé Jul 20 '16 at 14:48

Browse other questions tagged or ask your own question.