0

Using ArcGIS 10.2.2 for Desktop, I simply want to create a copy of one of the columns in my attribute table. I created a new column by choosing 'add field' in the attribute table, however I can't copy and paste the entire column of data from one of my attributes into this new field. How can I do this?

  • @PolyGeo Thanks. Itried that, but I am getting an error that reads 'The calculated value is invalid for the row with objectid=6. For example, the calculated value may be too large for the field or you may be trying to add a string to a number field, This row will not be updated'. I think I probably have to 'tell' arcgis that the column data I'm trying to copy are in fact numbers and not strings? – new2matlab Jul 20 '16 at 15:44
  • 3
    Make sure the field type and length are identical, for both the old and new fields. – cl3 Jul 20 '16 at 15:46
  • @cI3 Yes. They are the same length. On says in it's properties 'Data: Length: 80' while the other says 'Data: Precision:4'...so it seems you are correct and they are not the same. How do I make them the same? – new2matlab Jul 20 '16 at 15:50
  • It looks to me that the types differ then. One is a string (length: 80) and the other is float/double. – cl3 Jul 20 '16 at 16:58
3

You need to use the Field Calculator or Calculate Field tool to calculate your new field equal to your old field.

Make sure that your new field is defined the same as the old field. Otherwise it cannot be considered to be a copy.

  • Thanks. I am searching online for a way to define the field type and from what I can gather, I can not change the field type? If that is the case, is it not possible to copy a column in an attribute table if some of the rows are defined as text (or something that the field calculator doesn't like)? – new2matlab Jul 20 '16 at 16:01
  • You may need to delete the new field and add it again taking care to make them the same. You may be able to alter your new field but it will depend on your version and data format. – PolyGeo Jul 20 '16 at 16:04
  • Thanks. That worked. I defined the data type when I created a new column with the 'add field' option. I chose it to be long integer and it seems to have done the trick and allowed the calculator to copy over each of the rows in the original column. – new2matlab Jul 20 '16 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.