3

Input parametersI've installed QGIS 2.14.4 LTR (32 bit) on my WIN7 64bit system. But I believe something is wrong with the "Processing" plugin as many of the features were missing from what I've used earlier. My QGIS window didn't have any Simple/Advance interface option for switching between various providers in the processing toolbox.

Also the option for setting path was not seen in processing>>Options>>Providers>>SAGA The toolbox showed 235 SAGA Algorithms(with options such as "Grid Tools" still missing) but running them resulted in following error msg

 *****************************************************************
 Uncaught error while executing algorithm
        Traceback (most recent call last):
          File "C:/PROGRA~2/QGIS21~1.4/apps/qgis-ltr/./python/plugins\processing\core\GeoAlgorithm.py", line 203, in execute
            self.processAlgorithm(progress)
          File "C:/PROGRA~2/QGIS21~1.4/apps/qgis-ltr/./python/plugins\processing\algs\saga\SagaAlgorithm212.py", line 134, in processAlgorithm
            filename = dataobjects.exportVectorLayer(layer)
          File "C:/PROGRA~2/QGIS21~1.4/apps/qgis-ltr/./python/plugins\processing\tools\dataobjects.py", line 321, in exportVectorLayer
            if not os.path.splitext()[2] in supported or not isASCII:
        TypeError: splitext() takes exactly 1 argument (0 given)

The issues are presented/highlighted in the attached image.

I've tried the OSGEO Network installer as well as the standalone installer. I've uninstalled qgis several times and subsequently cleaned the registry and recycled the system (deleted the .qgis2 folder) for the next installation. But the result is the same.

QGIS window with processing options hihglighted

Error while running SAGA algorithms

  • The first screenshot looks ok, same for me in 32bit and 64bit. The error is related to the input values of the algorithm. Please include a snapshot of that, and describe the layer you are working on. Avoid non-ASCII filenames or field names. – AndreJ Jul 21 '16 at 6:03
  • So were the simple/advance interface and saga path setting option removed from the processing menu option?? – Srijith Jul 21 '16 at 6:29
  • 1
    Yes. The simple interface was more annoying than helpful, so it was removed. SAGA seems to be auto-detected, so no need to enter the path anymore. GRASS however still needs the path. – AndreJ Jul 21 '16 at 8:15
  • That's a new info for me. I've added the input parameter details in the image section. I tried to interpolate annual rainfall over a rain gauge network using spline interpolation. The layer was in UTM projection – Srijith Jul 21 '16 at 8:19
2

I have tested your workcase, and I get the same error with QGIS 2.14.4 32bit and 64bit.

However, it works on QGIS 2.16.0 64bit on the same computer, and 2.14.1 on another.

So maybe you can upgrade to QGIS 2.16. Standalone Windows versions can run in parallel. You might return to 2.14.4 after running SAGA if you prefer.

See https://issues.qgis.org/issues/15320 for progress on the bugfix.


UPDATE

the issue should be fixed by now, but it may take some time to get into the downloadable binaries.

  • It worked in qgis 2.16.0. But another problem is appearing "ERROR 1: Can't load requested DLL: C:\OSGEO4~1\apps\saga\dll\gdal_MrSID.dll 127: The specified procedure could not be found." Some algorithms (like spline) complete their run irrespective of the error but some (like variogram surface) just ends with this error code. – Srijith Jul 21 '16 at 20:11
  • MrSID.dll is already there. Also some of the tools (like GRID TOOLS) are still not integrated in this QGIS version. As suggested by @ahmadhanb below, I'm now switching between qgis n saga. Hope the reason for this error surfaces soon. Also some – Srijith Jul 22 '16 at 9:11
  • See sourceforge.net/p/saga-gis/support-requests/9 and osgeo-org.1560.x6.nabble.com/… about the gdal_MrSID.dll error. – AndreJ Jul 22 '16 at 12:08
1

You need to download OSGeo4W Network Installer, then double click the EXE file, select Advance install and follow the steps until you find the following window:

![enter image description here

Make sure to install Grass 7.0.4 with QGIS 2.14.4 (Long Term Release), and SAGA 2.1.2.

QGIS 2.16 is the latest, you can download it if you want to see the latest features of QGIS, but the Long Term Release is the stable version. Then continue with the installation process. When the installation finish, open QGIS -> Go to Processing menu -> Options and activate SAGA from there. Then enable Processing Toolbox to start using SAGA tools.

  • I tried the installation via OSGEO installer in the first time itself with the same results. Anyhow I've uninstalled all the current versions of QGIS and will be trying OSGEO installer once again. Will update the results – Srijith Jul 21 '16 at 6:18
  • Nothing has changed , there's still no option for path setting for SAGA in Processing>>Options>>Providers>>SAGA and the error msgs are still there – Srijith Jul 21 '16 at 7:06
  • Can you open SAGA successfully as a standalone, not from QGIS? – ahmadhanb Jul 21 '16 at 7:08
  • yes, I can open the SAGA as standalone. – Srijith Jul 21 '16 at 7:16
  • It is not a perfect solution, but you can do the processing you want using the tool you need from SAGA directly, and open the result in QGIS. – ahmadhanb Jul 21 '16 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.