6

The set-up: I am using ArcGIS 10.3. I have exactly 528 raster maps in a mosaic dataset. Each one corresponds to the same geography but at different months (from January 1969 to December 2012). I would like to use time-slider to move through these images and export to a video.

The time-slider animates nicely through the rasters inside ArcGIS, but once I try to export it to an .avi video it skips the large majority of images and I end up with only about every sixth raster being displayed.

Potentially relevant: the time-slider is operating on a string field that is the concatenated year and month (YYYYMM format). I created this field using the field calculator. It looks like this:

enter image description here

I picked this format because it fits one of the options in the Layer Properties dialogue. Note that in this dialogue I do not set the layer time extent because if I have ArcGIS calculate it directly, it decides the time starts at 1/1/0001 for some reason (this is highlighted in the next picture)

enter image description here

So in the time-slider properties dialogue, I change 1/1/0001 to 1/1/1969 and it seems to work fine. From here, the animation works in ArcGIS.

enter image description here

Using the default settings (below) to export to video causes the skipping. When I tested the default settings on a smaller subset (24 months) it worked fine. It's hard to test settings on the whole thing since the video usually takes a long time to export (and often doesn't work if I open any windows over the top of it).

enter image description here

closed as off-topic by PolyGeo Sep 23 '16 at 23:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I think you should take a step back and go to the simplest thing that you tried which was the first one and provide more precise details of what you tried and where you were stuck. If our expert volunteers can get you past that then the rest of your investigation becomes moot. What version of ArcGIS for Desktop are you using? – PolyGeo Jul 20 '16 at 23:14
  • 1
    I agree with @PolyGeo, without having access to 500 rasters it will be difficult to replicate the issue and help, so go back to step 1. My gut feeling is that it's probably some default setting you want to change in time slider or layer properties. May be Arcmap has set some time step automatically based upon your inputs and you just need to reset it? – Hornbydd Jul 21 '16 at 9:05
  • 1
    @PolyGeo - thanks for the very good point. I will edit the question significantly to start at the beginning. One question at a time :) – HFBrowning Jul 21 '16 at 15:26
  • @HFBrowning , Try to use Date field type instead of text for your date field to see if it works. – Farid Cheraghi Aug 27 '16 at 8:20
  • 1
    I was having similar problems, but they resolved when I switched to ArcGIS Pro to export my final animations. If that software is an option, I would use it. – Map Man Aug 30 '16 at 14:06