5

I just upgraded from Qgis 2.14 to 2.16 and I can't get the Globe plugin to work. Apparently, under Ubuntu it is necessary to install it separately. But in the Ubuntugis repository, only version 2.14 of qgis-plugin-globe is available and Synaptic refuses to install it:

qgis-plugin-globe:
  Depends: qgis (=2.14.3+dfsg-2~trusty1) but 1:2.16.0+20trusty is to be installed
 Depends: libopenscenegraph100v5 but it is not going to be installed
 Depends: libosgearth3 but it is not going to be installed
 Depends: libosgearthqt3 but it is not going to be installed
 Depends: libosgearthutil3 but it is not going to be installed

Any idea how to get this plugin to work?

2
+100

It seems like you need Ubuntu Xenial to get Globe for 2.16.

I got the following explanation on the QGIS mailing list by Jürgen:

Globe is only include where osgearth 2.7 is available (ie. debian unstable has it, ubuntugis xenial has it IIRC).

For 2.14 it's inverse, there globe is only available where osgearth<2.7 is available.

  • On Ubuntu 14.04 I have QGIS 2.14 and osgearth 2.4.0+dfsg-6 and yet Globe plugin do not show in plugins list – the world is not flat Sep 13 '16 at 14:01
3

Simple rule: If you want to stick to a Ubuntu LTS (14.04), you must stick to QGIS LTR (2.14.4). Or get the latest from both worlds (16.04 and 2.16.0).

The developers decided to do no additional backporting. You might well pay a developer for it if you can't/won't compile yourself.

  • That's a new rule to me. Can you point to a source? – Matthias Kuhn Jul 31 '16 at 18:46
  • I'm afraid I can not ;-) But it makes some sense to me. – AndreJ Jul 31 '16 at 18:50
  • It does indeed. But if this is a written rule, I will be very happy to know so I can adjust :) As far as I know, this is just a coincidence. Normally things are pretty much compatible across different versions. – Matthias Kuhn Jul 31 '16 at 18:59
2

As outlined by @underdark, the globe plugin which is shipped with QGIS 2.16 depends on osgEarth 2.7 which is not available out of the box on ubuntu 14.04.

Your options are:

  • Upgrade to yakkety yak or use xenial with ubuntugis unstable
  • Stick to QGIS 2.14
  • Compile osgEarth and then QGIS (with globe enabled) yourself
    • Directly from source (when compiling QGIS you will have to set some paths to osgEarth includ/lib directories)
    • You can try to backport packages from yakkety
  • I had QGIS 2.16 installed on a fresh Ubuntu 16.04 and was wondering why the globe plugin worked for me, but not for others... – AndreJ Jul 31 '16 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.