0

I am unable to install spatialite-gui using the ubuntugis unstable ppa. There appears to be a conflict between the GEOs libraries required by QGIS, which I installed first successfully (GEOS 3.5.0 automatically installed as a dependency), and the GEOS libraries required by spatialite-gui. Here is the error I receive when trying to install spatialite-gui:

The following packages have unmet dependencies:
 spatialite-gui : Depends: libgeos-c1 (>= 3.4.2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I try to install libgeos-c1, I see that this install would remove my QGIS install. Is is possible to have both QGIS and spatialite-gui installed from ubuntugis ppa, either w/ GEOS 3.5 or another version?

Edit: Ubuntu 14.04.4 QGIS 2.16.0

  • 1
    Which version of Ubuntu? which version of QGIS? – Micha Jul 23 '16 at 9:59
  • 1
    I can verify the prob on ubuntu 14.04. I guess that spatialite_gui will need to be repackaged with the newer geos and gdal libraries. – Micha Jul 23 '16 at 13:25
1

The maintainer of ubuntugis has been rebuilding all packages related to gdal and the new geos libraries. Spatialite_gui should be available soon. Here's his message:

Thanks for reporting this issue, I've rebuilt spatialite-gui for the geos transition in ubuntugis-unstable and uploaded the new revision (1.7.1-5~trusty3) to my staging PPA.

I've copied the packages to the ubuntugis-unstable PPA after the builds were confirmed successful in my staging PPA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.