0

I am running GRASS 7.3 on Mac OS X El Capitan (2.9GHz, 8GB RAM). I have had to disable SIP in order to run it, but it works. I am hoping to perform some hydrological analyses on a few DEMs. My DEMs are 5ft resolution county-scale rasters totaling a few GB apiece but I have performed lots of large-raster operations (outside of GRASS) on this machine with no issues.

When I run r.fill.dir, everything goes smoothly at first; the input raster loads quickly and within the first 5 minutes or so the first two sets of downward/upward passes have completed. Downward pass 3 takes several hours(~5.5 - 6.5) before the command apparently finishes successfully. However, when I look for the output rasters, they do not exist.

I have tried this multiple times, including with a reprojected version of the raster. Same result each time. I always make sure to set the region to match my raster before running the command.

  • How big is the region? Can you try on a small subset of DEM (say 1000x1000 pixels)? – Micha Jul 25 '16 at 7:27
  • The region is pretty big — 22609 x 50989. Not sure how this compares in the scheme of things, but it is a countywide raster after all. I tried your suggestion and used g.region to set a smaller region extent (~5000 x 5000 cells). r.fill.dir completed succesfully in just a couple of minutes. The interesting thing (to me) is that r.fill.dir does not crash and claims to finish successfully when I run it on the entire raster. Not sure what this would mean. Could it be a memory issue? I thought 8gb would be adequate – corvus Jul 25 '16 at 18:19
  • Note that a region of 22,000 X 51,000 is >1.1 billion cells. The module produces both elevation (probably Float32 ?) and direction maps. So each will be several gigabytes. You might indeed be running out of memory. Are you sure you need such high resolution for a country scale? – Micha Jul 26 '16 at 8:24
  • I am interested in assessing sinkholes on a county level, so it would be ideal to be able to maintain the original resolution, and to be able to run it as one raster vs having to do it in pieces… even though it does seem (based on my testing of smaller extents) that it might be significantly faster to process the county in portions by adjusting the region in GRASS. – corvus Jul 26 '16 at 14:21
  • After trying the same process on a region of ~450 million cells, I had similar results — it took less time than my attempts at processing the whole raster, but about 52 minutes to finish all in all. And no output raster to be found. If this is indeed a memory issue, which would seem to make sense, is there anything I might do (like memory allocation or something) which could improve performance or allow the process finish successfully? – corvus Jul 26 '16 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.