0

I am using cartoDB and Postgres 9.3 including PostGIS. When I try to create development user in cartoDB I get this error:

'CREATE EXTENSION IF NOT EXISTS odbc_fdw SCHEMA public;'
ERROR:  could not open extension control file "/usr/share/postgresql/9.3/extension/odbc_fdw.control": No such file or directory

Also, when I try to run odbc_fdw extension inside Postgres I get the same error.

Any idea how to fix it?

2 Answers 2

0

The odbc_fdw extension is an optional component for CARTO, which should work fine without it. It requires PostgreSQL 9.5 so you would not be able to use it with 9.3 anyway.

But the error your experiencing should be prevented by this: https://github.com/CartoDB/cartodb/commit/8c3a6e41

Can you check your code in db_service.rb for the presence of rescue Sequel::DatabaseError?

2
  • Just checked db_service.rb there is rescue Sequel::DatabaseError
    – VNenad
    Jul 26, 2016 at 13:14
  • I deleted everything related to install_odbc_fdw and it works now. Hope it was clever. But in the following, I get this error: PG::Error: ERROR: role "cdb_org_member_cd4c6486da97f514ce4aaec5338e2296" does not exist. Is this something related to the previous issue?
    – VNenad
    Jul 26, 2016 at 15:18
0

This is an old question but I came across it and wanted to shed the light on this cdb_org_member_xxxxx" does not exist issue. This issue is caused by your having the "cartodb" extension in the template_postgis database. Remove that extension from the template_postgis and you will resolve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.