6

All of a sudden, QGIS 2.14.4 hangs on startup on Win7 for at least 2 min. Eventually it starts without error. Hardware is not the issue (Core i7, 8GB ram, etc.). I tried reinstalling with OS4Geo installer and with standalone installer, but no change. I even cleared registry entries and .qgis2 folder. This error began after trying to connect/use a bluetooth GPS with the GPS Tools plugin. QGIS also freezes for a minute when clicking the GPS Tools button, so I suspect that this performance issue relates to the plugin in some way.

Any idea how to improve startup time?

enter image description here

UPDATE: Having uninstalled/reinstalled multiple times, deleted .qgis2 folder, and cleared registry, QGIS 2.14.4 still takes several minutes to start. I may try 2.16.1. Any insight into the processes running during the "Setting up the GUI" stage might be helpful.

UPDATE 2: Version 2.16 has been installed with the same result. For some reason, when my computer is connected to the network via an ethernet connection, QGIS takes 4-5min (as detailed above). However, when connected to my network via wifi, QGIS opens in about 20 seconds.

2

I started experiencing this issue today with QGIS 2.18.12 (Las Palmas) on WinServer 2008r2 in mid-session (for which I have no explanation, although Firefox also hung, whilst a number of other applications continued to run happily).

Thereafter, QGIS start-up hung at 'setting up the GUI'

The issue appears to be that the path to %OSGEO4W_ROOT%\apps\qgis\bin gets lost (which is where the GUI library qgis_gui.dll is stored). I managed to get QGIS to run by:

  1. Run OSGeo4W Shell (as described above), either from start menu, or by running [QGIS-installation-folder]\OSGeo4W.bat
  2. extend the PATH environment variable for the shell:

    path %OSGEO4W_ROOT%\apps\qgis\bin;%PATH%
    
  3. Run QGIS from command prompt in OSGeo4W Shell (again as above):

    qgis
    
  4. (and now for the weird bit) try running it from the normal shortcut - for me QGIS has started working again.

Good luck!

2

I know this question is a little bit old, but I installed GIS 2.6.1 a couple of weeks ago into my computer (Win10, i7, 250GB SSD, 8GB RAM) and in some occasions, the starting images freezes in the same point as asked Setting up the GUI Setting up the GUI

I tried to kill the process but it did not respond, so the only way to end it was turning off the computer and switching it back some time afterwards. This was annoying so I digged a little bit more into the program as I thought it was something to do with the installation.

What I did was to run the program from the Windows Commander Prompt in the directory where it was installed. In my case:

C:\Program Files (x86)\QGIS Brighton\bin

and typed the following, to see if some errors showed up:

>qgis-bin.exe

And it showed three error screens telling me that it could not find three .dll files:

  • qgis_gui.dll
  • qgis_core.dll
  • qgis_analysis.dll

I searched for them in the file explorer and they actually were in the installation folder, but not in the right path. I found them in:

C:\Program Files (x86)\QGIS Brighton\apps\qgis\bin

(I do not know why) So I copied and pasted them into the folder with the executable and tried again with the Commander Prompt.

This time I got another error, which told me that QGIS wasn't able to find Plugins archives, so I went to

C:\Program Files (x86)\QGIS Brighton\apps\qgis\

And copied the folder "plugins" which I pasted into the executable folder. Then, I run it again without furhter errors showing up and now it works perfect everytime.

1

I would do the following to increase startup time:

  1. First run the OSGeo4W Shell command program and enter the following to load QGIS without plugins (should load a little quicker):

    qgis --noplugins
    
  2. When QGIS is loaded, from the menubar go to:

    Plugins > Manage and Install Plugins...
    

    Then go to the Settings tab and make sure the Check for updates on startup option is disabled:

    Disable check updates

  3. Now go to the Installed tab and you might see that some plugins are enabled (but they won't be loaded). Disable any plugins you do not use.

  4. Quit QGIS. Hopefully the next time you start it again, it won't take as long.

  • All good suggestions, but no go. I actually tried to disable all plugins and it still hangs on startup for 2min. – Cliff Jul 29 '16 at 20:15
  • @Cliff - Interesting, not really a fix but have you tried installing the new QGIS 2.16? – Joseph Aug 1 '16 at 9:11
  • 1
    Unfortunately I need to use the 2.14 as it is used in my organization. I did reinstall after deleting the registry entries again, which seemed to work. – Cliff Aug 1 '16 at 12:22
  • @Cliff - Hopefully it worked, not a lot of fun if you have to wait minutes for QGIS to load each time :) – Joseph Aug 1 '16 at 12:24
  • 1
    Starting QGIS from the shell with --noplugins took almost 2:30 minutes. Closing and restarting with --noplugins took 6 seconds while re-launching QGIS from Windows start menu took 10 seconds. So yes, launching first time around is taking ages. I'm doubting the various database and server connections (Spatialite, WMS...) Does QGIS connect to all these services before loading and if so, maybe disable these checks to be performed post software loading? – Techie_Gus May 2 '17 at 16:28
0

I've been struggling with this for a while. If my Windows 7 X64 system hangs on "Starting up GUI" it will never come back and eventually ends with a blue screen system crash. It seems network related and I used to disable the network adapter before starting QGIS with mixed results. It's nuts but here's what works for me: start QGIS with the network cable unplugged. If it hangs plug the network cable back in. When the network comes up QGIS finishes its startup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.