I have DEM file for a small mountain created from TIN interpolation of points. The DEM looks correct on the flat QGIS working area. The moment I try to visualize a 3D of the DEM using threejs, I get infinitely high column without the mountain surface.

Column like DEM

I use Balkan Zone 7 as CRS, and my scale and shift option for the threejs plugin are set like this: -Base size: 100 -Vertical exaggeration: 1.5 (default, I tried '0', but I get flat terrain) -Vertical shift: 0

  • 3
    What are the horizontal and vertical units? If the first is degrees and the latter meters I think that the result would be a magician's hat. Some related information about the "scale" option in gdal.org/gdaldem.html.
    – user30184
    Jul 27, 2016 at 21:14
  • I think I may have found solution for my problem: I added the -z values for the contours, but not the x or y coordinates. I have created a DEM based on contours that have -z values, but QGIS can't really locate it in space. The result therefore is the magicians hat.
    – escplat12
    Jul 27, 2016 at 22:18

2 Answers 2


You can find a value somewhere between 1.5 and 0 that should suffice for visualizing the data. I often find that something in the 0.01 - 0.001 range for the vertical exaggeration is appropriate for getting a reasonable visualization of the data. You have to play with the vertical exaggeration a bit to find what works.

Unfortunately I am unsure of a way to display the data "to scale" -- but this might be a reasonable solution depending upon whether or not you require to scale visualization.


It's my understanding that if you set your data all to 3857 (per the Qgis2threejs docs) then your data will be in the same scale. From reading around other questions, it seems the important thing is that your projection is one whose units is meters.

You still might want to set the vertical exaggeration depending on what you want to show.

From the docs:

Click the CRS icon CRS status icon in the bottom-right corner of the window to open the project properties dialog. Activate the Enable 'on the fly' CRS transformation checkbox and then select a suitable CRS for the DEM extent. If you don’t know which CRS is best suited, select the Spherical Mercator projection (EPSG:3857), which is adopted by many web maps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.