1

I am using ArcGIS 10.3.1 for Desktop.

I am working on a polygon layer in GDB file and i want that every feature that have been created in the map will be the date of creation (date and datetime). I created a field named "date" and choose "Date" in the Data Type

enter image description here

but the problem is that when i digitized a polygon in the map, the date hasn't added to the attribute table:

enter image description here

4
  • 5
    Have you tried editor tracking?
    – GISGe
    Jul 28, 2016 at 11:50
  • i work with 10.3.1
    – newGIS
    Jul 28, 2016 at 12:30
  • 2
    Editor tracking was available at least as far back as 10.1. It is available in your version Jul 28, 2016 at 12:49
  • this option is blocked.
    – newGIS
    Jul 28, 2016 at 13:10

1 Answer 1

3

You appear to be confusing "attributes" and "values". By selecting the [Data Type] as "date" you are informing ArcGIS that this field or column will contain dates. You have not told ArcGIS what those dates are. If you were to add another field or column and set the [Data Type] as "text" would you expect Arc to populate it with the word "text"?

The [Data Type] is important because in GDBs (and many other database types) you cannot mix data types within the same field or column. With your "Date" data type you can enter dates. You could not enter the text "Date not recorded".

As suggested in the comment, Editor Tracking might suit your needs. In order to enable it, open Arc Catalog and navigate to your feature class.

Right click > manage > enable editor tracking

enter image description here

6
  • the "Enable Editor Tracking" option is blocked. why is it?
    – newGIS
    Jul 28, 2016 at 13:06
  • 1
    @newGIS - Is your dataset open in another instance of ArcGIS (e.g. ArcMap)?
    – GISGe
    Jul 28, 2016 at 13:22
  • no it isn't open in another place
    – newGIS
    Jul 28, 2016 at 13:42
  • 1
    Are you currently in a editing session? Please add a screen shot (similar to the one in my answer) to your original post. Jul 28, 2016 at 16:19
  • 1
    It worked out now, after i restart the computer
    – newGIS
    Jul 31, 2016 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.