I am using QGIS 2.16 / Windows 10.

I have a point shapefile which I have been using for a little while that has always been editable.

Today I was editing the layer, saved my edits and left my computer for a few hours. When I came back I was not able to toggle the editing button on the toolbar and when I right click on the layer it longer has toggle editing as an option.

I have googled the problem every way I can think of and have not been able to find an answer to why the layer is suddenly un-editable or how to fix this.

  • 2
    is there an active query on the shapefile? have you tried restarting qgis? is the shapefile used by any other application? – vagvaf Jul 29 '16 at 5:52
  • What version QGIS? What OS? Did u use a Filter? – nielsgerrits Jul 29 '16 at 5:52
  • 1
    So, I don't have any active querries, I've restarted QGIS twice to no use and teh shapefile is only open in QGIS. The folder that holds it isn't even open in Windows explorer. I'm using QGIS 2.16.0 on Windows 10, no filters. The only thing I have that affects the layer is a label by expression. – Ben Jul 29 '16 at 6:16
  • Shape local or network? If local, boot system to check if lock has disappeared. If network, might be another user / application. Really sounds like a locking issue to me. Could me the size as well. What is the size of the data? Components can have a max size. (2GB?). – nielsgerrits Jul 29 '16 at 6:37
  • So kid you not I just left my computer for half an hour, came back, right clicked on the layer and toggle editing is back. I have absolutely no idea what is going on. – Ben Jul 29 '16 at 7:14

It happened the same to me. Sometimes QGIS (2.18.11) blocks the edition when you "save as..." your project. Just remove the shp from the box and import it again. That should work. If not, save your layer as a new shp.

It also happens with duplicate layers.

  • 1
    Happened to me in QGIS 3 with a layer imported from a zipfile. Unzipping the file before import solved it. – melboiko May 22 at 17:29
  • with me it was when loading it from a url. Downloading the file and opening again solved it – hansaplast Nov 11 at 13:30

This is one kind of Bug coming from 2.8.4 Version. some times it happens when you keep Double clicking on the layers . I have faced the same kind of issue. may be your issue can be resolved if you can Disable the Layers option and enable it again.

Try this way

after loading the shape files go to View > Panels > Layers [ Disable/ Uncheck]

then go to the same place and enable the layers option.

I hope it works for you as well.

I found that enabling snapping (Snapping Panel) and disabling the Enable snapping on intersections, restores editing function.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.