I am using QGIS 2.16 / Windows 10.

I have a point shapefile which I have been using for a little while that has always been editable.

Today I was editing the layer, saved my edits and left my computer for a few hours. When I came back I was not able to toggle the editing button on the toolbar and when I right click on the layer it longer has toggle editing as an option.

I have googled the problem every way I can think of and have not been able to find an answer to why the layer is suddenly un-editable or how to fix this.

  • 3
    is there an active query on the shapefile? have you tried restarting qgis? is the shapefile used by any other application?
    – vagvaf
    Commented Jul 29, 2016 at 5:52
  • What version QGIS? What OS? Did u use a Filter? Commented Jul 29, 2016 at 5:52
  • 1
    So, I don't have any active querries, I've restarted QGIS twice to no use and teh shapefile is only open in QGIS. The folder that holds it isn't even open in Windows explorer. I'm using QGIS 2.16.0 on Windows 10, no filters. The only thing I have that affects the layer is a label by expression.
    – Ben
    Commented Jul 29, 2016 at 6:16
  • Shape local or network? If local, boot system to check if lock has disappeared. If network, might be another user / application. Really sounds like a locking issue to me. Could me the size as well. What is the size of the data? Components can have a max size. (2GB?). Commented Jul 29, 2016 at 6:37
  • So kid you not I just left my computer for half an hour, came back, right clicked on the layer and toggle editing is back. I have absolutely no idea what is going on.
    – Ben
    Commented Jul 29, 2016 at 7:14

7 Answers 7


It happened the same to me. Sometimes QGIS (2.18.11) blocks the edition when you "save as..." your project. Just remove the shp from the box and import it again. That should work. If not, save your layer as a new shp.

It also happens with duplicate layers.

  • 4
    Happened to me in QGIS 3 with a layer imported from a zipfile. Unzipping the file before import solved it. Commented May 22, 2018 at 17:29
  • with me it was when loading it from a url. Downloading the file and opening again solved it
    – hansaplast
    Commented Nov 11, 2018 at 13:30
  • It also happened to me when connecting to PostGIS on QGIS 3.4. Simply removing and readding the layer back the map will solve this.
    – Zac
    Commented Apr 1, 2020 at 23:20

I had this issue, and it was with a layer that was imported directly from a zipped folder. After unzipping the original folder, and re-importing the shapefile from the unzipped folder, I was able to edit it.


I had the same problem.

Solution: Along the top menu, Layer \ Save as. This exports the layer, and creates a copy inserted above the existing layer in the Layers Panel. When I did this, the new copy was editable.


This is one kind of Bug coming from 2.8.4 Version. some times it happens when you keep Double clicking on the layers . I have faced the same kind of issue. may be your issue can be resolved if you can Disable the Layers option and enable it again.

Try this way

after loading the shape files go to View > Panels > Layers [ Disable/ Uncheck]

then go to the same place and enable the layers option.

I hope it works for you as well.


I found that enabling snapping (Snapping Panel) and disabling the Enable snapping on intersections, restores editing function.


I imported my point files as a delimininated text layer (originally) and was unable to edit. If you then save layer as a shapefile or export as a geopackage, this might help. It did for me but mine was originally a different file format


Simply highlight the shp file and all it sub-files. Then right click and choose properties. Then uncheck the read-only, afterwards restart QGIS and you're all set.

Not the answer you're looking for? Browse other questions tagged or ask your own question.