5

I use Windows 10 OS and not good at coding. I have been using QGIS standalone installer for a long time (from 1.8 actually), but recently tried installing the OSGEO4W 32 bit version which had the latest QGIS 2.16 version, but when I load the application I get this error and none of the plugins show up, even the ftools (vector analysis). I have attached the error message below.

I did search for solutions, where I found some discussions talking about "python-future" but I don't know what to do exactly with that downloaded folder.

I tried pasting that folder content inside this path "C:\OSGeo4W\apps\Python27\Lib\site-packages\future" and restarted the application and it still didn't fix anything.

Can anyone provide a solution? Error message is provided below.

"**Couldn't load QGIS utils.
Python support will be disabled.**


Traceback (most recent call last):
  File "", line 1, in 
  File "C:/OSGeo4W/apps/qgis/./python\qgis\utils.py", line 21, in 
standard_library.install_aliases()
  File "C:\OSGeo4W\apps\Python27\lib\site-packages\future\standard_library\__init__.py", line 457, in install_aliases
__import__(oldmodname)
  File "C:\OSGeo4W\apps\Python27\lib\site-packages\future\backports\__init__.py", line 17, in 
from .misc import (ceil,
  File "C:\OSGeo4W\apps\Python27\lib\site-packages\future\backports\misc.py", line 24, in 
from socket import getaddrinfo, SOCK_STREAM, error, socket
  File "C:\OSGeo4W\apps\Python27\lib\socket.py", line 68, in 
from _ssl import \
ImportError: cannot import name RAND_egd


Python version:
2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]

QGIS version:
2.16.0-Nødebo 'Nødebo', d0b3e39

Python path:
['C:/OSGeo4W/apps/qgis/./python', u'C:/Users/Satish/.qgis2/python', u'C:/Users/Satish/.qgis2/python/plugins', 'C:/OSGeo4W/apps/qgis/./python/plugins', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\matplotlib-1.3.1-py2.7-win32.egg', 'c:\\osgeo4w\\apps\\python27\\lib\\site-packages\\python_dateutil-2.2-py2.7.egg', 'C:\\OSGeo4W\\bin\\python27.zip', 'C:\\OSGeo4W\\apps\\Python27\\DLLs', 'C:\\OSGeo4W\\apps\\Python27\\lib', 'C:\\OSGeo4W\\apps\\Python27\\lib\\plat-win', 'C:\\OSGeo4W\\apps\\Python27\\lib\\lib-tk', 'C:\\OSGeo4W\\bin', 'C:\\OSGeo4W\\apps\\Python27', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\PIL', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\jinja2-2.7.2-py2.7.egg', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\markupsafe-0.23-py2.7-win32.egg', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\pytz-2014.2-py2.7.egg', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\win32\\lib', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Pythonwin', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\Shapely-1.2.18-py2.7-win32.egg', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\six-1.10.0-py2.7.egg', 'C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\wx-2.8-msw-unicode']"
2

Re-run the setup.exe again, choose advanced install, then click on View to toggle from category to full.

Navigate to python-future. It should have been selected by default (version 0.15.2-1), but some earlier versions did not add it as dependency.

The installer should install the package in the right folder.

BTW QGIS 2.16.1 is out now. Maybe installing that fixes your problem too.

  • 1
    Thanks for your reply, I tried reinstalling that library alone with the latest version 2.16.1.. Still the same error persists.. – user2358205 Aug 1 '16 at 11:54
  • Alternatively, you could try the standalone installer, which uses different folders. Your error message is handled at stack overflow too: stackoverflow.com/questions/31762371/…. Maybe the solutions there work for you. – AndreJ Aug 1 '16 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.