2

I've looked hard for answers to this and whilst there is a fair bit on geometric network datasets in ArcGIS, I'm yet to have found an answer to this question, so fingers crossed this is not a double post.

I'm researching river networks and need to construct simple, directed graphs that eventually will be generated by classifying rasters, conversion to shapefiles/feature classes and then collapsing rasters to channel centrelines (points and polylines). The network effectively consists of channels (edges) connecting bifurcations and confluences (nodes).

I have built a geometric network from point and polyline feature classes and set connectivity rules for edges to connect to nodes/junctions and when I use the verify connectivity tool in the Geometric Network Editing toolbar it says "all network connectivity is correct". However, when I use the validate feature tool in the standard Editor toolbar, I get a message that says "edge features cannot connect to edge features via junction features" (see below). Does anyone know how to fix this problem?

Validate features connectivity problem

| improve this question | | | | |
  • 1
    Please only ask one question per question. Either refine down to the one question you want to ask, or ask a separate question for each. Recommend you take the tour – Midavalo Aug 1 '16 at 19:45
  • 1
    You refer to an Esri White Paper - can you please include a link to that white paper? – Midavalo Aug 1 '16 at 19:45
  • 1
    Are the lines that your selected feature connects broken/split at the point of connection? Is your geometric network set up using Simple or Complex edges? – Midavalo Aug 1 '16 at 19:46
  • Thanks for the input Midavalo and noted, only one question per question in future. – CryMeA_River Aug 3 '16 at 8:21
  • This is the ESRI white paper: downloads.esri.com/support/whitepapers/other_/… – CryMeA_River Aug 3 '16 at 8:22