I've added a WMS layer (from a GeoServer) in ArcMap and trying to apply a filter (~definition Query?) so only features with certain attributes are displayed.

I want to filter on attribute RedlistCategory = CR

Is it possible to do this under layer properties (right click on Map Service in ArcMAP), parameters tab? What should i type in Parameter and Value? Maybe this is not the place to apply filters?

enter image description here

I've been Reading this but i dont understand what to type in Parameter and Value: GeoServer help - WMS vendor parameters

From the WMS documentation: &Filter=<Filter><PropertyIsEqualTo><PropertyName>RedlistCategory</PropertyName> <Literal>CR</Literal></PropertyIsEqualTo></Filter>&format=image/tiff Is this useful?

WMS documentation (Swedish)

  • 1
    I never used ArcGis, but if you can add custom parameters, I'd go for CQL_FILTER, with a value of RedlistCategory = "CR" Aug 3, 2016 at 8:30
  • Did you try what @AndreaAime suggested? If it worked can you write that as an answer, please?
    – PolyGeo
    Sep 30, 2016 at 8:26

1 Answer 1


From @AndreaAime's comment i added CQL_FILTER as Parameter and RedlistCategory = 'CR' as value. CR need to be inclosed in ' signs (with " signs i get an error): enter image description here

  • What version of ArcGIS are you using? When I go to the properties for my WMS layer, I do not have a 'Parameters' tab. I am using ArcMap 10.3. Jun 8, 2017 at 18:42
  • @user13706: I Think i was using 10.4. Are you clicking at the right level in the "tree"? In my screenshot i click the "Geoserver Web Map Service" not "All Swedish Occurences"
    – BERA
    Jun 8, 2017 at 18:57
  • Thanks! Yes, I was doing it the way you describe. I'm upgrading to 10.5 now, and will make sure I have the Interoperability extension installed, so we'll see if that does the trick. Jun 8, 2017 at 19:35
  • I believe the issue was that 10.3 did not provide this functionality. After upgrading to 10.5, and installing the Data Interoperability extension, I have the Parameters tab, like you. I tried disabling the Interoperability extension, and it's still there, so I think it's related to ArcGIS version, not the extension. Thanks for your quick feedback! Jun 8, 2017 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.