3

I'm trying to hide some columns in my vector data attribute table: Layer properties - Fields - Widget Properties - Hidden. This should result in the fields being invisible in the attribute table. However, it doesn't work in my case - the hidden fields still show up (with their values visible), even after closing and re-opening the attribute table. Has anyone had this problem and knows how to solve it?

2

Setting the widget to "hidden" means that there will be no input widget in feature forms. This is not meant to affect the attribute table!

Columns in the attribute table can be hidden by right clicking the field name header and "Hide column".

enter image description here

Source: http://changelog.qgis.org/en/qgis/version/2.16.0/#new-configuration-options-for-attribute-table

  • 2
    Note: this behavior changed between 2.14 and 2.16. – Matthias Kuhn Aug 3 '16 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.