2

QGIS novice here. I have a shapefile for US census PUMA (public use microdata areas). One of the attributes in my shapefile is the metropolitan area of the PUMA. I want to combine PUMA's which are located in the same metropolitan area. To do this, I am using the dissolve command, and choosing the metropolitan area attribute as the dissolve field. For most of the United States, things work as expected, but there are a few areas in which there is weird behaviour. For example, instead of combining the Chicago pumas into a big polygon, QGIS redraws a Chicago polygon of slightly different size. See the following pictures to see what I mean:

screenshot 1 screenshot 2

Is this a QGIS bug, or is there something I am doing wrong? Is there anything I might try to fix this behaviour?

  • Are all the files in the same coordinate system? – Ed Rollason Aug 4 '16 at 8:51
  • Yes the project is all in WGS84 / Pseudo Mercator. The only input shape file is the PUMA data from the census. – veryshuai Aug 4 '16 at 8:59
  • @dof1985 points out below that I was actually using NAD83, ESPG: 4269 (as can be seen in the lower right hand corner of the images included in my question). – veryshuai Aug 4 '16 at 11:06
1

I solved this problem by installing GRASS, importing the shapefile there, and running v.dissolve using the metropolitan area attribute. The dissolve worked flawlessly as expected.

  • It is very interesting, your problem there. I wonder what was the cause of it. BTW note that you are not in Pseudo Mercator - rather you were at NAD83, ESPG: 4269 – dof1985 Aug 4 '16 at 10:56
  • Oh, yes, I reported that incorrectly. I'll add that as an edit above. – veryshuai Aug 4 '16 at 11:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.