1

I'm using QGIS 2.16 but this was happening on 2.14 as well and I hoped updating would fix it but no.

I create a new shapefile, doesn't matter whether it's a point, line or polygon, toggle edit function, and then use the edit add feature function to add a feature to the new shapefile. When right-clicking to finish my new feature the feature attributes window pops up but it is blank and I can't edit the attribute which means I can't add the feature. See the image.

I suspect there is a conflict with some other software on my computer or a previous version hasn't been removed completely because I have been having trouble with browsers and videos as well. I have tried using the tools of CCleaner to tidy up my registry and redundant files. I tried updating from 2.14 to 2.16 and I have tried removing 2.16 cleaning everything and reinstalling 2.16 but the problem still exists. Can anybody offer some advice of what else to try?

screenshot of blank feature attributes pop up

Note the other edit tools work such as copy, paste, move and node tool and my work around is to copy and paste a feature then reshape with node tool or move it but this is slow. None of the add... tools work.

  • in the table try adding a column (using the table editor) If you having issues projection might not be set when creating a shapefile. workaround get a shapefile (of the web) and delete all geometry and then create your own fields. – Mapperz Aug 5 '16 at 2:45
  • Thanks for the suggestion but none of that works. I used to be able to add features to shapefiles and have tried existing and new shapefiles with project CRS matching shapefile CRS and have tried adding additional attribute fields, – Tracey Aug 5 '16 at 5:33
  • Can you edit existing, older shapefiles? – AndreJ Aug 5 '16 at 5:49
  • No I can't add features to existing shapefiles. I used to be able to but now I get the blank feature attribute window. – Tracey Aug 5 '16 at 8:30
  • Try to uninstall your QGIS from your machine, install updates to your operating system and reinstall QGIS. – Zoltan Jun 25 '17 at 11:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.