5

After switching from 2.14.1 to 2.16.1 adding layers from a certain WFS results in an error, example is with version 1.0.0 forced:

Layer is not valid: The layer srsname='EPSG:28992' typename='app:Bouwvlak' url='http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?' version='1.0.0' table="" sql= is not a valid layer and can not be added to the map

QGIS WFS log:

Analysis of DescribeFeatureType response failed for url srsname='EPSG:28992' typename='app:Bouwvlak' url='http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?' version='1.0.0' table="" sql=: Cannot find element 'Bouwvlak'

I guess the problem is in parsing the DescribeFeatureType response, but I do find the element 'Bouwvlak':

...
<element name="Bouwvlak" substitutionGroup="gml:_Feature">
    <complexType>
        <complexContent>
            <extension base="gml:AbstractFeatureType">
                <sequence>
                    <element name="fid" type="integer"/>
                    <element name="bestemmingsvlak" minOccurs="0" type="string"/>
                    <element name="historisch" minOccurs="0" type="boolean"/>
                    <element name="identificatie" minOccurs="0" type="string"/>
                    <element name="naam" minOccurs="0" type="string"/>
                    <element name="plangebied" minOccurs="0" type="string"/>
                    <element name="planstatus" minOccurs="0" type="string"/>
                    <element name="typePlan" minOccurs="0" type="string"/>
                    <element name="versieIMRO" minOccurs="0" type="string"/>
                    <element name="verwijzingNaarObjectgerichteTekst" minOccurs="0" type="string"/>
                    <element name="geometrie" minOccurs="0" type="gml:GeometryPropertyType"/>
                    <element name="dossierID" minOccurs="0" type="string"/>
                    <element name="dossierStatus" minOccurs="0" type="string"/>
                    <element name="datum" minOccurs="0" type="string"/>
                    <element name="verwijzingNaarExternPlan" minOccurs="0" type="string"/>
                </sequence>
            </extension>
        </complexContent>
    </complexType>
</element>
...

What I tried:

  • loading the features with FME - works
  • manual request in browser - works
  • force version to 1.0 / 1.1 / 2.0 in QGIS - no luck
  • ignore axis orientation in QGIS - no luck
  • Using Wireshark I checked the differences in requests from 2.14.1 and 2.16.1:

2.14.1 requests:

GetCapabilities

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&REQUEST=GetCapabilities&VERSION=1.0.0

DescribeFeatureType

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&VERSION=1.0.0&TYPENAME=app:Bouwvlak&&REQUEST=DescribeFeatureType

GetFeature (1)

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetFeature&TYPENAME=app:Bouwvlak&SRSNAME=urn:ogc:def:crs:EPSG::28992&MAXFEATURES=1

GetFeature (all)

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetFeature&TYPENAME=app:Bouwvlak&SRSNAME=urn:ogc:def:crs:EPSG::28992

GetCapabilities

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&VERSION=1.0.0&REQUEST=GetCapabilities&TYPENAME=app:Bouwvlak&SRSNAME=urn:ogc:def:crs:EPSG::28992

2.16.1 request

GetCapabilities

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&REQUEST=GetCapabilities&ACCEPTVERSIONS=2.0.0,1.1.0,1.0.0

DescribeFeatureType

http://afnemers.ruimtelijkeplannen.nl/afnemers2012/services?SERVICE=WFS&REQUEST=DescribeFeatureType&VERSION=2.0.0&TYPENAME=app:Bouwvlak

No differences up to this step, so now I am stuck. Switching back to 2.14 works but I prefer using 2.16.

Can someone tell me this is a bug or a problem in the service?

  • 2
    I confirm I get the same error with my QGIS 2.16.0 install on Windows. I note that if I use the WFS 2.0 client plugin, then I can get the data, so that might be a workaround for you. – nmtoken Aug 5 '16 at 11:22
  • Could you provide your update as answer, so its directly obvious, it has been fixed already? – tareq Aug 10 '16 at 6:59
1

Logged this as an issue (http://hub.qgis.org/issues/15395) at 05-08-2016. Closed / fixed 09-08-2016 (thats quick) with the comment:

Fixed per 4bcbc1e (and backported in master_2 in f17f6ac, and in release-2_16 a0e3e76)

I'm not sure how the release cycle works and when the fix will be available but will update.


In my current installation this issue is fixed.

QGIS version 2.16.2
QGIS code revision 979e1a2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.