So I just installed QGIS 2.16, and when trying to run grass commands specifically r.watershed, i get the following error, Missing dependency. enter image description here

which seemed to be similar to this issue QGIS 2.14 standalone GRASS provider missing Msys folder, can't execute tools so I tried out the solution 'aQGISuser' suggested and downloaded the msys base package, changed the path settings in QGIS but I still get the following error. Wrong value for parameter "R folder" Can anyone help?

enter image description here

2 Answers 2


It looks like you are working with an older version of the processing plugin.

Take a look into C:\users\<username>\.qgis2\python\plugins and delete any folder named processing.

The current core version does not need the msys folder for GRASS 7 commands, only GRASS (which is GRASS 6.4.3) still needs it.

r.watershed is included in GRASS and GRASS7, so I suggest to deactivate GRASS to avoid the MSYS folder problem. The standalone QGIS 2.16.1 version does not include GRASS 6 anymore, only 7.0.4. The Grass folder you specified would not be correct anyway, it should point to the subfolder grass-6.4.3 (if that is installed).

The R folder has nothing to do with GRASS, but with scripts for R. Since you don't want to use that, you might deactivate the R data provider in the Processing options as well.

  • Hey, so I deleted the processing folder you mentioned, then deactivated Grass. R was already deactivated. But then when I hit OK in the processing options window it gives me the same error message as before. "Wrong value for parameter R folder" and when I hit cancel and reopen Processing options Grass is still activated, so my change wasn't saved. The error is weird because I didn't touch the R folder field in the first place. The error just came up after I changed the Msys folder field to C:\MinGW\msys. The problem with r.watershed still remains. Thanks for the help! Aug 5, 2016 at 16:31
  • Maybe start with removing the entry for the R folder, or change it to an existing folder. I guess you have removed QGIS Lyon already.
    – AndreJ
    Aug 5, 2016 at 16:54
  • That didn't work either. Yep, uninstalled Lyon, my mistake! would it help to reinstall 2.16? Aug 5, 2016 at 18:37
  • Uninstalling Lyon was not a mistake. Without a folder for R and Grass (not Grass 7), did you get rid of the Missing R folder? If you select r.watershed, don't take the one from GRASS, but from Grass 7.
    – AndreJ
    Aug 6, 2016 at 5:37
  • Hey, so I reinstalled 2.16,then removed the values for the Grass- Msys folder and R Scripts- R folder and deactivated both and didn't receive any error message. Earlier i would get an error message if I deactivated the Grass folder and then hit ok. Also tried r.watershed from Grass 7 and it works just fine. Problem solved. Just had a couple of follow up doubts. What should the default value for R folder be, in case I want to run scripts in the future? I also want to submit an answer to my question, what could I say was the main issue? Just that Grass (v6) had to be deactivated? Thanks! Aug 6, 2016 at 13:57

Same happened to me, but what I did was to set the correct path "QGIS 2.16"instead of "QGISLY~1" and to create a placebo folder named "msys" in the expected place so the final address is "C:\Program Files\QGIS 2.16\apps\msys" and it worked. Hope this helps. Cheers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.