4

I am iterating through ~300 raster tiles, using a polygon feature class to extract by mask. The model successfully processes the first ~100 tiles and then I get the following error on the same tile each time:

ERROR 999999: Error executing function. The table was not found. [VAT_T2001]

ERROR 010092: Invalid output extent. Failed to execute (ExtractByMask).

I changed the extent parameter of the extract by mask tool from default to "intersection of inputs" and got the same error for the same tile. The tool seems to work fine when I change the extent parameter to "union of inputs" but it takes an extremely long time to process each tile.

I thought that the error might be occurring because there is no overlap between the error tile and the mask feature class, but I confirmed that the tool successfully processes other tiles where there is no overlap.

The tiles and the feature class have the same spatial reference. The error also occurs for a handful of other tiles in the data set.

Does anyone know how to resolve these errors while maintaining efficient processing?

The model is just an iterator sitting in front of the extract by mask tool. So this is a question about why extract by mask works for some raster datasets and not others when the datasets have the same attributes and the tool has the same parameters.

  • What happens when you make the dataset which throws the error be the first one processed? Can you reproduce this error outside your model? – PolyGeo Aug 5 '16 at 22:39
  • When the model processes the problematic tiles first, I get the same error. When I replicate the function outside of the model with the problematic tile, I also get the same error. I also found a few other tiles that cause the error, but I can't figure out what differentiates the problematic tiles from the others. – Christopher Aug 5 '16 at 23:33
  • In that case I think you should use the edit button to heavily revise this from being a ModelBuilder issue to being an issue with Extract By Mask on particular data inputs. – PolyGeo Aug 5 '16 at 23:50
  • What are the parameter settings that you are using when you see the error on one particular data input? These are some previous Q&As that may help: gis.stackexchange.com/search?q=%5Bextract-by-mask%5D+999999 – PolyGeo Aug 9 '16 at 7:23
  • It also worked for me when I did not change the default save location and output file name. It's better than nothing. I can use the output anyhow... – user87211 Nov 29 '16 at 18:10
3

I have encountered this error multiple times but still havent figured out why exactly it happens. The only thing that always works for me is when I dont change the default save location (default geodatabase) and output file name. Then the tool works correctly for some reason. As soon as I select my own workspace to save the output or rename the output in the tool dialogue box, the error re-appears. Dont know if this will help you since you have so many rasters.

  • This worked for me, though I'm also not sure why this happens. I'm still getting the same error when I use the iterator, but this should be enough to construct some sort of workaround. Thanks! – Christopher Aug 11 '16 at 15:30
2

This error and many others happens, when vector and raster coordinate system are different, you must change both to same coordinate system and it will work hopefully without errors in future. :)

2

The output raster needs to be saved in a file geodatabase instead of a normal folder. This will stop the unknown error: 999999

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.