I have used a Google Maps hybrid layer in Openlayers in my HTML5 iOS app for months now and it worked perfectly. Just recently they changed something because the 'Map data...' line at the bottom looks different (light grey background) and whenever you touch the screen or the map position is updated via navigator.geolocation.getCurrentPosition() the map data copyright box pops up.

Has anyone else experienced this? If so I'd really appreciate any info on any solutions/workarounds you've found.

  • 1
    do you have live link to your map?
    – Mapperz
    Feb 20 '12 at 17:03
  • Mapperz comment is especially valid here. Google Maps can only be used on a public web site (unless you pay big $, min 10K per year). "iOS app" doesn't sound like a "public web site" for me... Feb 20 '12 at 20:12
  • 1
    This is true where websites are concerned. Though it isn't spelled out in their terms of service, what I've heard from other mobile developers is that the exception to this is mobile apps. If you think about it, by using a Google OL layer in an app (unless you obscure the copyright notices, etc.) you are doing exactly the same thing as using the built-in MapKit class in iOS, which is obviously okay with Google since they collaborated with Apple to put it there.
    – kschaos
    Feb 23 '12 at 15:12
  • @kschaos your comment above, about Apple and Google being OK with each other, is hilariously out of date 2 years later Jun 6 '14 at 3:14

I saw this answer on the Openlayers mailing list a few days ago. You need to make sure you are providing a version, such as v=3.6:

<script type="text/javascript" src="http://maps.googleapis.com/maps/api/js?sensor=false&v=3.6"></script>

Then it should disappear.

-- May 17, 2012 edit:

I just saw that this problem has returned on the OpenLayers mailing list. A suggested fix (which worked for me) is to paste the following into the openlayers style.css

.olLayerGooglePoweredBy.olLayerGoogleV3.gmnoprint {

Not sure if this is "legal" but i just made it go away with CSS.

.olLayerGoogleCopyright {display:none;} 


Apparently this violates the terms of use:

By doing so, you violate the Terms of Use. Instead, you should use a more recent version of OpenLayers - this problem was fixed in 2.11.

Are you using 2.11? Apparently it's no longer a problem.

-- May 17, 2012 edit: (per celenius comment)


8.5 Proprietary Rights Notices. You agree that you will not remove, obscure, or alter any proprietary rights notices (including copyright and trademark notices, Terms of Use links, or Brand Features) that may be affixed to or provided through the Service. Where such notices are not affixed within the Service, you agree to display such notices according to the Maps APIs Documentation.

  • 1
    Correct it is breaking the terms. You answer makes it possible to do it and the intention is good, though would not advise any user/client Google lawyer that it was done.
    – Mapperz
    Feb 20 '12 at 22:18
  • @CaptDragon - just curious about the terms of use comment. I see the comment in the thread but there is no link to anything further; do you know where I can read about this? I ask as the popup is now appearing 2.11 as of today. Thanks.
    – djq
    May 17 '12 at 4:50
  • @celenius : see my edit
    – CaptDragon
    May 17 '12 at 13:17

OpenLayers 2.11 is not compatible with the current “frozen” and “release” versions of Google Maps API. Either migrate to 2.12 RC5 or read this: http://trac.osgeo.org/openlayers/wiki/Release/2.11/GoogleMaps37.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.