3

QGIS Version: 2.14.3 GRASS Version: 7.2

Both installed via Homebrew.

Tried setting the GRASS7 path in "Processing->Options" but QGIS does not accept it.

enter image description here

Related to the following questions:

QGIS 2.14.1 LAStools install error: "wrong value for parameter 'Msys folder'..."

QGIS GRASS Missing Dependancy

Grass7 processing toolbox QGIS

Update:

I modified grassPath() in "Grass7Utils.py" and changed the grass path folder setting to:

folder = '/usr/local/Cellar/grass-72/HEAD-/grass-7.2.svn/'
return folder

Checking the processing options in QGIS, the path change was accepted. However, GRASS7 algorithms still come up with the error message that GRASS7 is not configured correctly. Which GRASS path does QGIS need?

enter image description here

  • Any success with this? Same issue on 'normal' install (kyngchaos), OS X 10.10.5 – Simbamangu Sep 29 '16 at 15:48
  • I had the same issue and your solution worked for me on Windows 10 and QGIS 3.8 (installed using osggeo4w) – MappaGnosis Sep 12 at 12:46
1

I had the same issue and I found out that grass is located in

/usr/local/opt/grass7/grass-base

enter image description here

or at least is how homebrew configures it when you install it using

brew install qgis2 --with-grass --with-saga-gis-lts

I have to use instead

brew install qgis2 --with-grass

because saga gis lts gave me a source problem.

curl: (22) The requested URL returned error: 404 Not Found
Error: Failed to download resource "saga-gis-lts"
Download failed: https://downloads.sourceforge.net/project/sagagis/SAGA%20-%202.3/SAGA%202.3.1/saga_2.3.1.tar.gz

that I'm trying to figure out.

1

This seems to work:

A) Note that there are two paths: "GRASS7 folder", and then a few lines below it "GRASS folder". I set them both to the new value. B) To set them, it's not enough to type in the value and hit "OK"; you have to type in the value, press Return, and then press the "OK" button.

I'm using the Kyngchaos distribution of QGIS 2.18.4 on OS X. According to Mr. Kyngesburye, to access the internal version of Grass, you should be pointing to the folder '/Applications/QGIS.app/Contents/MacOS/grass7' (which is correct, at least for my version). The Processing plugin was initially broken so I couldn't even get to its option panel, but re-opening QGIS fixed it. Ghosts in the machine!

0

This issue has resurfaced with 3.2.3 The bundled grass folder is not called grass7 and all attempts at changing the path to match fail. Instead install the Grass package from http://grassmac.wikidot.com/downloads and point the "GRASS7 folder" setting at /Applications/GRASS-7.4.1.app/Contents/MacOS and and the Grass docs setting to /Applications/GRASS-7.4.1.app/Contents/Resources/docs/html

Bulky and not terribly neat but functional

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.