1

I'm trying to convert GEOPDF files to MBTiles using QGIS on mac. I'm using GDAL version 1.11.4, QGIS version 2.8.9. I am doing this by raster -> translate -> input layer GEOPDF file, output file MBTile file. I have tried setting expand to Grey, RGB and RGBA but they all give the same error. "band 1 has no colour table".

I have installed the GEOPDF Plugin for GDAL.

I have found questions with similar issues and they all point to using "1-Band Raster Colour Table" Plugin but this does not work with the current version of QGIS.

I tried reverting back to earlier version of QGIS but then I couldn't get QGIS to read GEOPDF files.

I can use QGIS to export geotiff files from the PDF files and then use Map tiler to get the MBTile but it would be much easier if I could just do it all on QGIS.

closed as off-topic by underdark Mar 30 '18 at 19:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – underdark
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Can you give a link to a sample GeoPDF file? – AndreJ Aug 10 '16 at 5:41