1

I have proj4 version 4.9.2 installed in a non-standard location within a Linux environment (/p/bin/proj4). I know that proj_def.dat did not go out with version 4.9.1, but was of the understanding that it was included in version 4.9.2. I have verified that it works, I have added /p/bin/proj4/share/proj to my PATH. In addition, I downloaded the datum shifting files for North America to proj/conus. When I run R and load rgdal, I receive the message that Path to PROJ.4 shared files is autodetected. This is in contrast to gdal, which shows the correct path to my installation of gdal. I provided the following argument when I installed rgdal "--with-proj-share=/p/bin/proj 4/share/proj".

However, when I run raster(), I receive the following message:

rgdal::checkCRSArgs:: no proj_defs.dat in PROJ.4 shared files

I have verified that there is a proj_def.dat in proj/ folder.

Is their an argument that I can provide when loading rgdal that will point to the proj_defs.dat files.

  • Have you tried installing rgdal and including the option `with-proj-lib=/p/bin/proj4/lib' ? – dmci Aug 10 '16 at 18:55
  • yes, I also added '--with-proj-include=/p/bin/proj4/include' – user44796 Aug 11 '16 at 14:24
  • Check here for further details – dmci Aug 11 '16 at 16:58
  • I am currently using proj4 version 4.9.2, which theoretically solves the problem. In my case, it doesn't. I think that the answer is somewhere in the configure file for rgdal, – user44796 Aug 11 '16 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.