5

My original test (included at the bottom of this question) did not match completely the circumstances in which I see ArcMap unexpectedly skip a datum check between GCS_WGS_1984 and GCS_GDA_1994.

This is the test which I think will enable others to reproduce what I am seeing.

Using ArcGIS 10.4.1 for Desktop, I did the following:

  1. Started ArcMap with a Blank Map
  2. Added a shapefile with this coordinate system:

GCS_WGS_1984 WKID: 4326 Authority: EPSG

Angular Unit: Degree (0.0174532925199433) Prime Meridian: Greenwich (0.0) Datum: D_WGS_1984 Spheroid: WGS_1984 Semimajor Axis: 6378137.0 Semiminor Axis: 6356752.314245179 Inverse Flattening: 298.257223563

  1. Insert a second data frame
  2. Add a shapefile into this new data frame with this coordinate system:

GCS_GDA_1994 WKID: 4283 Authority: EPSG

Angular Unit: Degree (0.0174532925199433) Prime Meridian: Greenwich (0.0) Datum: D_GDA_1994 Spheroid: GRS_1980 Semimajor Axis: 6378137.0 Semiminor Axis: 6356752.314140356 Inverse Flattening: 298.257222101

  1. Add a second shapefile into the new data frame with this coordinate system:

GCS_WGS_1984 WKID: 4326 Authority: EPSG

Angular Unit: Degree (0.0174532925199433) Prime Meridian: Greenwich (0.0) Datum: D_WGS_1984 Spheroid: WGS_1984 Semimajor Axis: 6378137.0 Semiminor Axis: 6356752.314245179 Inverse Flattening: 298.257223563

In past versions at this point I would have expected to see a Geographic Coordinate Systems Warning because the second dataset added had a different datum (GCS_WGS_1984) to the first dataset added (GCS_GDA_1994) which set the data frame's coordinate system:

enter image description here

However, no warning appeared, and when I checked C:\Program Files (x86)\ArcGIS\Desktop10.4\Utilities\AdvancedArcMapSettings.exe, I was able to verify that I had not inadvertently checked the Don't warn me again ever check box as described on The geographic coordinate systems warning Help page.

enter image description here

Is the datum check in ArcMap sometimes being incorrectly skipped between GCS_WGS_1984 and GCS_GDA_1994?

This is what ArcMap and the second data frame Properties look like at this point, including what I see when I click the Transformations button.

enter image description here


This is the original test that I posted, and I agree with two answerers that it does not show what I was trying to. The software behaves as expected for the test below.

Using ArcGIS 10.4.1 for Desktop, I did the following:

  1. Started ArcMap with a Blank Map
  2. Added a shapefile with this coordinate system:

GCS_GDA_1994 WKID: 4283 Authority: EPSG

Angular Unit: Degree (0.0174532925199433) Prime Meridian: Greenwich (0.0) Datum: D_GDA_1994 Spheroid: GRS_1980 Semimajor Axis: 6378137.0 Semiminor Axis: 6356752.314140356 Inverse Flattening: 298.257222101

  1. Added a second shapefile with this coordinate system:

GCS_WGS_1984 WKID: 4326 Authority: EPSG

Angular Unit: Degree (0.0174532925199433) Prime Meridian: Greenwich (0.0) Datum: D_WGS_1984 Spheroid: WGS_1984 Semimajor Axis: 6378137.0 Semiminor Axis: 6356752.314245179 Inverse Flattening: 298.257223563

In past versions at this point I would have expected to see a Geographic Coordinate Systems Warning because the second dataset added had a different datum (GCS_WGS_1984) to the first dataset added (GCS_GDA_1994) which set the data frame's coordinate system:

enter image description here

However, no warning appeared, and when I checked C:\Program Files (x86)\ArcGIS\Desktop10.4\Utilities\AdvancedArcMapSettings.exe, I was able to verify that I had not inadvertently checked the Don't warn me again ever check box as described on The geographic coordinate systems warning Help page.

enter image description here

I know from the Inter-governmental Committee on Surveying and Mapping (in Australia) that:

for most practical purposes GDA94 and WGS84 coordinates can be considered the same and no transformation is required

but is the datum check in ArcMap now always skipped between GCS_WGS_1984 and GCS_GDA_1994?


Below are the *.prj files for the two orginal shapefiles and two additional shapefiles (generated using Create Fishnet) that I used in my testing:

enter image description here

closed as off-topic by PolyGeo Aug 15 '16 at 4:00

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • An interesting note on a comment in your question PolyGeo, GDA94 and WGS84 are only similar, not the same abc.net.au/news/2016-07-28/… and geoproject.com.au/gda.faq.html#q09 .. I only found out recently (I was always under the assumption they were interchangeable too) with the planned release of GDA2020 in 2017 icsm.gov.au/gda2020 not truly related to your problem but interesting nonetheless. – Michael Stimson Aug 15 '16 at 4:29
  • Are you using Add Data or drag-and-drop or copy-paste? The warning is inconsistently shown with the different methods of adding data, and there are some very old bugs in the system about it. We've just never gotten around to fixing it. (Disclosure: Esri employee) – mkennedy Aug 15 '16 at 17:40
  • @mkennedy I'm using drag and drop from the Catalog window throughout. – PolyGeo Aug 15 '16 at 19:56
2

You may have missed another setting somewhere (although I cannot find where - my settings appear to match yours.)

I have just tested in both 10.4 and 10.4.1 and can confirm that I received the Geographic Coordinate Systems Warning in both, including the option to set transformation between the two systems.

enter image description here

enter image description here


Have re-tested using the updated process and I still get the same result. The Geographic Coordinate Systems Warning message appears as soon as I add the second (different system) shapefile into the data frame.

(Note that the second shapefile doesn't appear in the ToC until after clicking Close on the Warning dialog)

enter image description here

  • Thanks for testing. I'll try a reboot (just restarted ArcMap on previous tests) and retest to see if the expected results reappear. I have a theory that there was a subtle difference between what I described and what I did so I'll test that tomorrow. – PolyGeo Aug 13 '16 at 10:45
  • Sorry - did not get time to re-test yesterday but hope to later today. – PolyGeo Aug 14 '16 at 21:29
  • I just posted the results of my retest. I agree with your result on my original test but I have now posted a fractionally longer test which I think does illustrate the issue that I observed, and can reproduce. – PolyGeo Aug 15 '16 at 2:06
  • @PolyGeo I have updated my answer including a screenshot of my latest test – Midavalo Aug 15 '16 at 2:36
  • That certainly seems to be the same workflow that I am using and you are using datasets with the same coordinate systems in the same order, so I am at a loss as to why we get different results. I'll try getting rid of my Normal.mxt and see if that makes a difference. – PolyGeo Aug 15 '16 at 3:08
2

Did you set a transformation from GCS_WGS_1984 to GCS_GDA_1994 in the transformation settings for your Data Frame such as noted in Midavalo's screen shot?

Set Transformation

Once this is set, ArcGIS will not issue a Geographic Coordinate Systems Warning for this specific transformation. If you saved the MXD you were working on, take a look at the transformation settings under View > Data Frame Properties > Coordinate System > Transformations to see what settings are in place. Otherwise, you should be getting the warning message.

  • Thanks for answering. I did not set a Transformation but the test I originally posted did not show what I thought it would. I just posted a fractionally longer test which I think does illustrate the issue that I observed, and can reproduce. – PolyGeo Aug 15 '16 at 2:08
  • I get the same expected results as Midavalo receiving a warning message upon adding the second file. 1) Please confirm the settings in your Geographic Coordinate System Transformations after adding the second file. It should list GCS_GDA_1994 and GCS_WGS_1984 using <None> as a Transformation. 2) Check the PRJ files contained with each of your shapefiles added to the project using a text editor. They should reference "GCS_GDA_1994" and "GCS_WGS_1984" accordingly. – user1565824 Aug 15 '16 at 3:27
  • 3) Is this occurring only on one system or any system you are using? If it is a single system you could try resetting your ArcGIS Normal.mxt. [Resetting your ArcGIS application profile] (geonet.esri.com/docs/DOC-2121) – user1565824 Aug 15 '16 at 3:44
  • At the moment I only have access to one system (my laptop). I've tried resetting the Normal.mxt which had no effect. The settings in my Geographic Coordinate System Transformations after adding the second file does list GCS_GDA_1994 and GCS_WGS_1984 using <None> as a Transformation. I'll check the *.prj files in a text editor now. – PolyGeo Aug 15 '16 at 4:03
  • I just added the *.prj files to the bottom of my question - they all look to be as expected. – PolyGeo Aug 15 '16 at 4:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.