2

I have installed QGIS 2.14.5.LTR via the OSGeo4W installer on Windows2008R2. No raster tools are available. After activating Gdal-Tools plugin, the raster tools are available, but cannot executed (because Gdal-Paths are not set?):

enter image description here

In the dialog under menu Raster > GdalTool-Settings... the paths to GdalTools can be set but C:\OSGeo4W\bin where these modules reside (gdalbuildvrt.exe e.g.) has no effect.

enter image description here

On the other hand, GdalTools via the processing toolbox can be executed without any problem:

enter image description here

I have no idea wether here is something wrong with my path settings or if it is an issue with the OSGeo4W installer. Any Ideas?

  • 1
    Under Windows (any version) there is no need to set any path regarding the so called "gdal tools". I believe that if that dialog shows then you have some kind of installation problem. Try also removing the .qgis2 folder and start QGIS again, maybe you have some old stuff in there. – Giovanni Manghi Aug 17 '16 at 7:19
  • tried to remove the .qgis2 folder, no effect. Added some additional info, cp. above. – Jochen Schwarze Aug 17 '16 at 9:08
  • Does it work if you copy the command line, and execute it in a batch file insdide the OSGEO4W shell? – AndreJ Aug 17 '16 at 9:19
  • If the gdal/ogr based tools are running ok in the Processing toolbox then it means the gdal/ogr installation that comes with QGIS is ok as also the paths. This issue is then some weird problem with the core plugin "gdal tools". I would suggest making a clean installation, this means also removing the QGIS registry keys after uninstalling the software. – Giovanni Manghi Aug 18 '16 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.