1

What I have is:

Output Area Polygon layer, Building Polygon layer, with Area stat appended, Union layer between the two above

The end goal is to be able to colour the Output Areas based on what amount of building area there is in each.

I've been trying to us GroupStats to try build that, but I've been getting errors that look like: "AttributeError:'NoneType' object has no attribute 'area'"

I take this to mean, the Output Areas that contain no buildings have Null entries in that field, and GroupStats can't handle that? I don't know though.

Does anyone know what I'm getting wrong here?

  • Did you join those layers? I haven't had problems with the plugin concerning NULL values as these are usually ignored (the plugin even mentions how many records have NULL values). – Joseph Aug 18 '16 at 10:43
1

I got around this problem, and here's how, but I'm still interested in hearing why this happens, and how better to go about dealing with it:

I selected the entire city, then deselected based on the expression

area IS NULL

This left only the polygons that matched the buildings, and these polygons had both the name of their Output Area and their defined area, so this would be sufficient.

Then in GroupStats I clicked "Use selected" and set it running, this time without any errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.