0

i'm not an expert about 3D reconstruction but i wanted to ask, what is the best method to import a 3D model (gained by using Structure from Motion tecniques). I used VisualSFM to generate the 3d reconstruction, and I got a .ply file as output. I now want to import it and analyse its elevation model, by using GRASS Gis, but I get this error:

(Fri Aug 19 11:38:27 2016)                                                      
g.extension.py extension=v.in.ply svnurl=http://svn.osgeo.org/grass/grass-addons/grass6
Fetching <v.in.ply> from GRASS-Addons SVN (be patient)...
Compiling...
Makefile:5: /usr/lib/grass64/include/Make/Script.make: No
such file or directory
make: *** No rule to make target
`/usr/lib/grass64/include/Make/Script.make'.  Stop.
ERROR: Compilation failed, sorry. Please check above error messages.
(Fri Aug 19 11:38:31 2016) Command finished (4 sec)  
  • 1
    Welcome to GIS SE! As a new user be sure to take the Tour to learn about our focussed Q&A format. I recommend not thinking about GIS SE as being some sort of online GIS tutor. For your questions to be answered here they should as much as possible describe not just what you want to do, but precisely what you have tried and where you are stuck trying that. – PolyGeo Aug 17 '16 at 23:52
  • @PolyGeo thank you very much for your answer. I tried to import my sparse cloud within Grass GIS by using the ply importer without results. I'm going to try again with the same add-on > grass.osgeo.org/grass70/manuals/addons/v.in.ply.html – user4330326 Aug 19 '16 at 0:04
  • Please use the edit button beneath your question to revise it with additional details at any time. Potential answerers, who are all volunteers, do not always have time to read the comments. – PolyGeo Aug 19 '16 at 0:07
1

Add-on v.in.ply works only for GRASS GIS 7, but you use 6.4, so I suggest upgrade. If I remember correctly v.in.ply will import only points, not the mesh if that's what you have. So then you will need to interpolate.

  • Installing GrassGIS 7.0 and the development package, I successfully installed the add-on. Thanks! Unfortunately I still cannot import my .ply file since I get this error: Importing 1327040 vertices ... ERROR: Wrong number of properties (Thu Aug 25 11:10:51 2016) Command finished (0 sec) Should I check the header of the .ply file or consider to load the xyz dataset connecting to a database? Otherwise I'm evaluating to rasterize the dataset though R or using k-nearest neighbour in python. – user4330326 Aug 25 '16 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.