I recently upgraded to ArcGIS 10.4.1 and overall I am liking it very well. There's just one annoying problem that has been occurring ever since the upgrade.

When I use the 'Find' tool after it has been closed out for awhile, ArcMap seems to hesitate and then pops up with the message: "You must be signed in to ArcGIS Online with an organization account to use the ArcGIS Online World Routing Service."

Full Screenshot of my ArcGIS window

Close-up of the message

Here are the exact steps I follow:

  1. open find features window
    1. input account number
    2. select layer to search and attribute to search
    3. search and find result
    4. right click result (this is when it seems to take longer than it used to)
    5. select 'zoom to' in drop down menu
    6. ArcMap zooms to property, blinks it and then instantly displays the message
    7. generally I hit cancel and continue my work, but it has become a nuisance

I definitely have a Legit copy of ArcMap and I do have an organization account at ESRI, but I don't want to be told to log into it everytime I search a property. I am not running any ESRI layers nor searching any world files. I am searching localized data that we build in house.

Why is this happening, and how do I fix it to where I'm not bombarded by this message everytime I search?

Edit: Adding screenshots of the other two tabs in the find tool for reference.

enter image description here

enter image description here

It only occurs when I right click the items in the results field. If I just do a quick double click it will zoom to them without displaying to message. It's just difficult for me to do that, because the way I learned was to right click and select zoom to.

Also it only occurs like the first time I use the find tool after it's been closed for awhile. So it's not absolutely preventing me from getting work done, I just know with ArcMap that almost everything comes down to a hidden checkbox or something that I'm not finding.

Edit: Adding additional screens to show this occurring with multiple layers within the same map.

enter image description here

I cannot, however, seem to replicate this with some of my more recent maps that I've created since updating. As per Simon's comment I will create a fresh version of the same map and see if that is the solution.

  • 1
    Can you include screenshots of the other two tabs in the Find dialog (Locations and Linear Referencing)? – Midavalo Aug 19 '16 at 17:48
  • @ Midavalo, I added the other screens. The fact that I didn't even realize the other two tabs were there makes me feel like a dunce :) and the find tool is like the most basic tool... I do this for a living I promise. – Joshua A Aug 19 '16 at 18:03
  • Do the other tabs matter though if I'm using 'find features' and assigning a specific attribute to search in? – Joshua A Aug 19 '16 at 18:06
  • 1
    No idea - I've never seen that message before, so wanted know if if your settings matched mine on all tabs, which they do. – Midavalo Aug 19 '16 at 18:07
  • 2
    Does this same behaviour happen for searching against other layers? Have you tried renaming normal.mxt (so it creates a fresh new one) and try again? I cannot replicate (not logged into AGO). – Simon Aug 25 '16 at 11:06

I'm fairly certain that it is occurring in the first place because the menu that displays after you right click your target shows Routing options to be implemented if you wish. See screenshot below.

Right-click Menu

As for fixing the pop up, I'm not aware of any way to disable it other than signing in (which you should be able to do once and it will leave you signed in every time you open ArcMap) or maybe by disabling your ArcGIS Online connection.

  • This doesn't really answer the question. I get those same options and I am not presented with the Sign-in message. – Midavalo Aug 19 '16 at 19:42

It's requiring the sign in because you are using the World Geocoder Service which is stored in ArcGIS Online and uses tokens which must be purchased by your organization.

Edit: It may fix the issue to change the geocoder to MGRS which is included in your license.

  • I still get the message when I switch to MGRS. I don't utilize the World Geocoder Service. I have used the find features tool for years and as far as I can remember I have never encountered this message until I updated to 10.4.1 I'm searching account numbers that are in the parcel layer that we build in house. I've tried logging into my ESRI account both from this message and from the outside and neither makes the message go away. – Joshua A Aug 25 '16 at 17:39
  • What version of ArcGIS did you upgrade from? In 10.4 the find tool requires it to be connected to a geocoding service. Is there a reason you don't use Select by Attribute queries? desktop.arcgis.com/en/arcmap/10.3/map/working-with-layers/… – Stephen Ruhl Aug 25 '16 at 18:44
  • I do use the Select by Attributes, but I don't always have my table view open. Also, I'm not always searching the same layer, so the 'find features' tool has been a good/fast/reliable means of searching an attribute and zooming there quickly, rather than opening separate tables and searching by attributes. – Joshua A Aug 25 '16 at 21:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.