1

When I copy a track (day) from a Garmin Oregon 550 to the PC an import it into Qgis a the timestamp is 2 hours earlier than it should be.

When I import it via Garmin Basecamp, export it and open it in Qgis the time stamp is still wrong. When I open the track in Basecamp the timestampes are correct.

When I import the same file in Geosetter (http://www.geosetter.de/) and synchronize images with the track it works fine (right positions).

The time on the device is the right time zone.

Question: Is there a simple way to import the track directly to Qgis with the right timestamps?

1

Timestamps in GPX files are always UTC, as received from the satellites.

The time zone setting on the device is only for display, with no influence on the track content.

Assuming you are living in central Europe, the offset is now 2 hours, and in winter one hour.

See How do I get an accurate time attribute when importing a GPX layer as a vector for a workaround.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.