3

I have been using word wrapping for my legends in ArcGIS 10.3. I have had some success with this, but am getting errors in the way the labels are displayed.

Here is a pic of the settings:

enter image description here

The error is in the pdf output. Sometimes the line will be wrapped, but the next line is missing.

In the following example, Towns and Villages (near top left) is cut off in the pdf output.

Here is the pdf output:

enter image description here

Here is the view from ArcMap:

enter image description here

I have searched online and have not been able to find any information about this error. Has anyone had this error and discovered a fix?

Here is what I have had success with so far:

  • Adding a space after the offending line makes it appear in the pdf output
  • Workaround by adding multiple line descriptions and using those in the legend

I have tried adjusting the gaps in the layout settings. This does not help. I have also tried changing the label width to different values. This also does not help.


I tried removing all other elements from the layout as Polygeo suggested. Once I removed the other layers from the layout, the legend displayed properly in the pdf output, with the lines broken at the correct place and all text showing. Then when I added all the layers back to the legend, it continued to display properly. I need to test this further, but at the moment it appears that turning off all layers except the affected one (towns and villages in my example) and then turning the layers back on will fix the legend.

This is strange behavior. The first time I opened the map today, I wrapped the labels in the legend and the label was cut off for towns and villages. Then I turned off all the other layers in the map, and the label was no longer cut off. I exported the map and the pdf output was fine. Then I turned all the layers back on and the label was still displaying correctly in the map and pdf. Then I restarted ArcMap expecting to get the wrapping error again, and I didn't get the error this time. I'll test this again tomorrow.

closed as off-topic by PolyGeo Jan 15 '17 at 2:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try to increase the gap values in the Gaps section. Maybe the wrapped label is hidden somewhere behind the second header. – ahmadhanb Aug 24 '16 at 2:30
  • @ahmadhanb - I have tried this and it does not help. Thanks for the suggestion tho. – jbalk Aug 24 '16 at 2:46
  • Anyone have any ideas? – jbalk Aug 31 '16 at 3:27
  • Is this a known bug?? – jbalk Aug 31 '16 at 3:27
  • Can you take everything out of your layout except the parts necessary to do that part of your legend and still see the problem? – PolyGeo Sep 24 '16 at 5:59