2

It just keeps minidumping.

Working on a big project and it just keeps mini-dumping, have even added more RAM to the computer to try make it easier. So far today I've reinstalled 2.16 (64bit), deleted all the errors in the users temp file and tried removing 'QGIS2' from the file path. I recreated the project (using the layers I've already made) and have got so far as trying to export the PDF from print composer before POW 'minidump written to C: \Users\Belinda\AppData\Temp\qgis-20160824-121716-5792-6496-8545b3b.dmp'

How do I get around this? What else can I try?

  • Have you tried turning off all plugins that you do not need? – artwork21 Aug 24 '16 at 11:36
  • Yes everything is uncrossed in plugin manager. – Belinda Aug 24 '16 at 11:43
1

It was an element within the layer! Just worked out which element it was via unclicking boxes of elements within the zone it kept breaking on until it would print compose, lots of clicking later worked out the element it didn't like. Changed the code for that element/item of the layer in the attribute table and gave it slightly different symbology and it its fine! Phew - thank you for all your responses. Hope this helps other people.

0

I would recommend starting simple, in new .qgs file load one layer and try pdf export. If that works, add more layers and do pdf export. If that works load as a template the large project composer and try pdf export. If that works add more layers that are in your large project .qgs file and try export. Keep increasing the .qgs project/composer complexity until you find the possible breaking point.

  • Thank you I have done that now, and it works all the way until the very last. So my map is split into 4 zones (ts a biggy) and all the layers work okay for 3 of the 4. But the last one just wont do it with my biggest and most time consuming layer. Do I need to redo that whole layer? – Belinda Aug 24 '16 at 12:11
  • Set a query filter (using Query Builder button) to make the large problematic data set much smaller and try pdf export. If that works, maybe try splitting out the large layer into smaller chunks (quadrant) and try pdf export with the four layers instead of the one big one. – artwork21 Aug 24 '16 at 12:23
  • Also, what data format is the large layer (shapefile, gdb, sqlite, PostGIS)? – artwork21 Aug 24 '16 at 12:25
  • its .shp at the moment. Thank you, I will try the query builder now, just need to add an attribute to split the data into zones. – Belinda Aug 24 '16 at 12:48
  • Oh no its back to mini-dump whenever I zoom to the zone I need to PDF it mini-dumps. – Belinda Aug 24 '16 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.