-1

I am trying to do a hydrological analysis in ArcGIS 10.3 using Taudem toolbox. I've installed the tool following the instructions that can be found here (http://hydrology.usu.edu/taudem/taudem5/downloads2.html). When I start the process with the pit removal, the tool gives me this error:

enter image description here

The Dem is in tiff format (I tried also with a .asc file), but the error continues.

  • Please provide all error messages as text rather than pictures so that they are available for future searches. – PolyGeo Aug 25 '16 at 9:56
2

The error message indicate a python dependency issue, specifically it can not find the numpy module.

I would guess this is one of the following:

  1. a python-path issue. Do you have multiple python installations eg 3 and 2?
  2. did you not have admin rights when installing TauDEM perhaps?
  3. Is Gdal installed

Test if the command line tools work if yes it's a python issue, if no its probably gdal

  • thanks for the reply. I've checked the command line. It works well, so maybe is a python issue. How could I solve it? – user66349 Aug 27 '16 at 13:46
  • This is tricky, i would try uninstalling and reinstalling, and check that the python paths are set correctly. Also, make sure you install as admin. You could just use the command line tools, these should be faster than the arcgis version, although not as interactive. – Tom Higginbottom Aug 31 '16 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.