0

I generated a shapefile that has 1ft contours. It works great when imported to QGIS except the elevation labels are displayed in meters instead of feet. I've found two places to select feet as the unit of measurement, but they are for distance and area, not elevation.

How do I get my 1 ft contour lines to display in feet instead of meters?

That is, I want: 18ft, 19ft, 20ft instead of 5.486m, 5.791m, 6.096m.

  • I have a work-around for now. I multiplied the elevation by 3.28084 in the expression editor and made it a whole number. But there's got to be a better way! – erkq Aug 30 '16 at 7:36
1

That will be in the attribute data of the contours. You'll probably have a column labelled 'ELEV' or something for the metre measurement. Just create a new column with the field calculator using:

'ELEV' / 0.3048

That should could a new column with all metre converted to feet. Then use that column to label the contours.

Alternatively for something not as permanent you can use the same equation as above in the label properties

  • Putting that conversion in label properties is what I found to do. Thanks for the column addition solution! That's probably best. – erkq Aug 30 '16 at 17:49
0

For QGIS look here.

Quote:

Choose menu option Settings ‣ Options, click on the Map tools tab and select the appropriate ellipsoid. There, you can also define a rubberband color and your preferred measurement units (meters or feet) and angle units (degrees, radians and gon).

  • Yes, I found that set of options and set the length to feet and area to square feet. But there's nothing for elevation and it kept showing in meters even after changing these settings. Very odd, huh? – erkq Aug 30 '16 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.