4

I have labels of a shapefile which I created through Easy Custom Labeling (labeling toolbar). I want to move the labels around manually to arrange them better but QGIS draws a line wherever I move them to. How can I disable this?

enter image description here

'Use custom dash pattern' was off anyway. I tried changing the line width to 0, even the pen to 'no pen' and also changed the value in the 'LblShowCO' column back to Null values. Still I have this annoying line :(

enter image description here

1

In EasyLabeling there is a column called LblShowCO which is set to 1 or 0 depending on if you have moved a label or not. This is used to control the custom dash string in the style:

CASE WHEN LblShowCO = 1 
THEN 
    '2;0' 
ELSE 
    '0;2' 
END 

The easiest way to turn off all leader lines is to turn off Use Custom Dash Pattern in the style. Or set the line to have 0 width, or you can either set all the values to that column to NULL or remove 0 and then remove the ELSE clause if you need to keep some of the lines.

  • Thanks for the suggestions. I tried everything but still the line is there (see screenshot above) – danielaandrea Sep 1 '16 at 7:56
  • 1
    Okay now I tried the 'no pen' option but without setting the width to 0 which worked! Weird but it worked :) – danielaandrea Sep 1 '16 at 7:57
1

You could use an alternative solution with the QGIS build-in solution to move labels by adding 2 real-type fields to your layer (LABEL_X and LABEL_Y for example). Then you define in its properties the two field to control X and Y coordinates of your label.

enter image description here

Then you use the label toolbar to move your labels... with no lines :

enter image description here

some more infos here : How does manual Label Placement in QGIS 1.9 work? (it works with QGIS 2.16)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.