1

I am trying to merge several (70 at least) raster files (a digital elevation model, ASTER DEM v2). I am using QGIS and I use the tool "Raster > Miscellaneous > Merge".

I works well and I get the new raster, but the elevation values are not concordant with the values on the original rasters. For instance, there are individual rasters with elevation >2000m, and in the new raster I get values until 1500m.

I have also used "Raster > Miscellaneous > Build Virtual Raster", but the same happens. I have tried as well to merge fewer raster files; it still does not work.

What should I do? Any suggestions?

  • been having the exact same problem – Rodrigues Jul 2 '17 at 23:32
2

Go to properties of the ASTER DEM layer and go to Style and do the following:

enter image description here

  1. Use Min/Max
  2. In the Extent, use Actual (Slower) => Load. Then check if the pixel values were updated or not.
  • After that, the range values are still the same... In the layer with the merged raster files and in the individual rasters... – Teresa Sep 2 '16 at 8:13
  • Have you tried both "Full extent" and "Current extent"? – ahmadhanb Sep 2 '16 at 8:31
  • I am trying now. This takes a while, maybe the last time I tried I didn't give it enough time. I will let you know if this works! – Teresa Sep 2 '16 at 9:45
  • The values change with the options "full extent" and "Actual (slower)". But it seems to take a very long time, I wasn't able to let the "load" finish yet... Do you know of any other option? Maybe using GRASS...? – Teresa Sep 2 '16 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.