1

I have an addin for ArcGis 10.0. This addin is developed in following environment:

  • Visual studio 2010 ,
  • ArcObjects sdk for 10.0 (arcgis)

When I want to use same addin on ArcGis 10.4 version, it does not work. Then I build my code on :

  • Visual studio 2015 community edition,
  • ArcObjects sdk for 10.4 (arcgis)

and it works fine.

Now, I want to know, is there any common environment where I build my code and run in both version of arcgis (10.4 and 10.0)?

closed as unclear what you're asking by PolyGeo Sep 4 '16 at 20:22

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    I always thought addins were upwardly compatible? Did you change which version of .net you compiled against? I have am addin compiled for arcgis 10.2, it definitely works on 10.4.1 – Hornbydd Sep 4 '16 at 17:57
  • 1
    "When I want to use same addin on ArcGis 10.4 version, it does not work" - what doesn't work? It won't load to ArcMap, or it gives errors when you try to run it, or it just doesn't do anything? – Midavalo Sep 4 '16 at 18:28
  • @Midavalo, in arcmap 10.4 , it won't load. – Monir Sep 5 '16 at 4:41
  • ArcGIS 10.0 is in Retired status. Compatibility across four releases is quite a stretch. Rather than setting that as your goal, why not use a code repository with two build environments. – Vince Sep 5 '16 at 13:26
  • thanks @Vince, Now I am doing so. If there is a common environment, it will be helpful. I have to support my addin software in both 10.0 and 10.4 – Monir Sep 6 '16 at 4:42