0

I need to use the "&" as the first character in my published parameter (a text parameter). It seems that using & as the first character makes an error in the parameter.

enter image description here

Any workarounds?

FME2015.1

  • Out of curiosity, why do you need to use an "&"? I can think of a few other alternative solutions but am wondering why you need it. – Fezter Sep 7 '16 at 23:11
2

It seems (in my testing) that it only happens the second time around - ie the first time you enter &aaaa (for example) it is OK. The second time you run the workspace the field is highlighted red.

But you can delete the contents and type &aaaa again and it is OK. At least, I can in my tests.

Basically it's parsing of the underlying mapping file interpreting this as an attribute value, since & always used to indicate an attribute name.

So you would always need to ensure that where you enter &aaaa, that aaaa is not also the name of an existing attribute.

The proper solution is to use a Multiline text parameter, instead of just text. That works better since it supports better encoding, the character is stored as <amp>, and it's recognized that this is not an attribute value.

| improve this answer | |
  • 1
    The Multiline text parameter worked. Thanks. I contacted Safe Software about this issues, they were able to reproduce this behavior, but no solution. Thanks~ – a1234 Sep 27 '16 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.