2

Total QGIS newbie here.

I installed 2.16.2 on a Dell Optiplex GX260 with Pentium 4 @ 2.4 or so Ghz, 2GB RAM. 30-something GB free on the hard disk after installation.

I started up the QGIS "desktop" (without GRASS) and tried to navigate to a folder containing ESRI shapefiles I wanted to edit. QGIS hangs up, apparently trying to open the directory, with a rotating "wait" icon on the directory. According to Task Manger, CPU use is pegged at 100%. Memory useage is at 859MB so I assume disk-swapping due to insufficient RAM isn't the problem.

I tried exiting the application normally, but qgis-bin.exe remained running, still pegging the CPU. Closing this module from task manager finally lets CPU usage return to the minimum.

Then if I re-start QGIS desktop, it makes an uncommanded return to the rotating wait icon on the same directory I previously tried to open. CPU usage goes back to 100% and stays there.

What should I try now? Is CPU speed the issue? Should I re-install on a faster one?

  • 1
    There are no real minimum specs out there for QGIS that I am aware of, but from what has been discussed your setup would meet the anecdotal minimum requirements, though it is definitely at the lower end of the scale. Did you have any previous versions of QGIS when you did the install? Where did you get the install file from? Any you running anything else in the background? – ed.hank Sep 10 '16 at 19:33
  • Did you use the browser panel or Add Vector layer? I always use the second, and never had such hangups. – AndreJ Sep 11 '16 at 5:37
  • Ed - I believe I downloaded from SourceForge. I recall installing QGIS once before, but I think it was on an older PC, so there probably weren't any lurking files and registry entries this time. Nothing else was running in the background. – LADave Sep 12 '16 at 13:54
  • Andre - I never really got to that point. I had just started it up and wanted to load an ESRI shapefile. As soon as I tried to open a folder one level above the one containing the shapefile, QGIS went out to lunch and never came back. – LADave Sep 12 '16 at 13:57
  • Update: I don't think navigating to a folder was the problem. I just tried again and here's what happened: Restart PC (Windows 7, SP1) Open QGIS 2.16 folder, start browser. Start Task Manager to monitor. CPU pegs before I do anything, qgis-browser-bin.exe is at 94-99% CPU utilization, memory ~700MB. I click shutdown X at upper right. Browser desktop closes but CPU stays 100%. Shut down app from TM applications panel, CPU still 100%. TM processes panel says qgis-browser-bin.exe still running at high CPU utilization. Use this panel to shut it down and CPU finally drops to ~10%. – LADave Sep 12 '16 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.