3

I had tried to install the latest QGIS following the commands listed on QGIS Documentation ; But they seem not to work for the arm architecture of Nvidia Jetson TX1 & i get a clash of the version number. Then i had reflashed my board Nvidia Jetson TX1 and installed QGIS old version. As anyone tried to install QGIS on arm64 Nvidia Jetson TX1 ?

Here is the result of uname -a

Linux tegra-ubuntu 3.10.96-tegra #1 SMP PREEMPT Tue May 17 16:29:05 PDT 2016 aarch64 aarch64 aarch64 GNU/Linux

My terminal output:

ubuntu@tegra-ubuntu:~$ sudo apt-get install qgis
[sudo] password for ubuntu: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qgis : Depends: qgis-providers (= 2.0.1-2build2) but it is not going to be installed
        Depends: qgis-common (= 2.0.1-2build2) but 2.8.3-0~trusty1 is to be installed
        Recommends: qgis-plugin-grass but it is not going to be installed
        Recommends: qgis-plugin-globe but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I tried to compile Grass according to Grass wiki But, i am not understand how to specify for grass build, the system type

ubuntu@tegra-ubuntu:/usr/local/src/proj$ ./configure  &&  make  &&  sudo make install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether ln -s works... yes
checking whether make sets $(MAKE)... (cached) yes
checking build system type... ./config.guess: unable to guess system type

This script, last modified 2007-03-06, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from

  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
and
  http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub

If the version you run (./config.guess) is already up to date, please
send the following data and any information you think might be
pertinent to <config-patches@gnu.org> in order to provide the needed
information to handle your system.

config.guess timestamp = 2007-03-06

uname -m = aarch64
uname -r = 3.10.96-tegra
uname -s = Linux
uname -v = #1 SMP PREEMPT Tue May 17 16:29:05 PDT 2016

/usr/bin/uname -p = 
/bin/uname -X     = 

hostinfo               = 
/bin/universe          = 
/usr/bin/arch -k       = 
/bin/arch              = 
/usr/bin/oslevel       = 
/usr/convex/getsysinfo = 

UNAME_MACHINE = aarch64
UNAME_RELEASE = 3.10.96-tegra
UNAME_SYSTEM  = Linux
UNAME_VERSION = #1 SMP PREEMPT Tue May 17 16:29:05 PDT 2016
configure: error: cannot guess build type; you must specify one
  • You can use the ubuntu-mate.org/download (raspberry pi) for your Nvidia Jetson TX1 then use PPA launchpad.net/~ubuntugis/+archive/ubuntu/ubuntugis-unstable to install the latest version. – Mapperz Sep 12 '16 at 19:06
  • @Mapperz the problem is the nvidia hardware features only work with 14.04 Ubuntu version, i need to stick with it; although i am not sure if they will be releasing or supporting ubuntu-mate ! – Akarsh SEGGEMU Sep 13 '16 at 20:02
  • There was Ubuntu 16.04 release recently, but the error is the same. I tried using the QGIS 2.8 Version but it crashes in the middle, when i try to download Sentinel 2 data. – Akarsh SEGGEMU Oct 7 '16 at 14:58
1

As can be seen from the FTP linked on the official [docs] you mention, there are no builds for ARM. Not even for 32-bit ARM. So you'll either have to build it yourself or find someone to crosscompile it for you. I'd start by looking at Raspbian package repositories, since it included QGIS and other GIS software in the past (and RPy uses ARM).

  • I tried to build from source following the tutorial. But i got the error of not finding the GRASSConfig.cmake file. Which i don't know how to find it. As i searched in the git repository, still no luck – Akarsh SEGGEMU Sep 11 '16 at 23:11
  • It's probably from GRASS sources. Did the Raspbian package not work for you? – lynxlynxlynx Sep 12 '16 at 6:35
  • I tried the Raspbian in terminal & got command not found error for deb http://archive.raspbian.org/raspbian wheezy main contrib non-free deb-src http://archive.raspbian.org/raspbian wheezy main contrib non-free – Akarsh SEGGEMU Sep 12 '16 at 8:00
  • You could use one of the mirrors then, but it also seems rpy uses a 32-bit arm ... so back to compiling. – lynxlynxlynx Sep 12 '16 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.