1

I can't seem to figure out how to not re-iterate through the beginning part of my model whereby I import a table from excel into a dbf and join it to the feature classes being iterated. I am copying over data from the imported table by carrying out a join and then just field calc-ing the joined fields over to the appropriate standard fields. The model works but with each iteration it re-imports the excel table, causing the whole process to take longer than needed.

How do I set up the model so that it only imports the excel table once?

Also, is there an easier way to import data from excel and populate into the appropriate fields than the way I'm doing it?

I've attached a screen shot below:enter image description here

3

The ModelBuilder is a bit strange when it comes to iterations (For example only one iterator per model).

To solve your problem you can integrate a model into another. You can then call the submodel with your table import into the original model and it should not be iterated. Some info here: http://desktop.arcgis.com/en/arcmap/10.3/analyze/modelbuilder/integrating-model-within-a-model.htm

A second option might be (did not test, but could work) is to load your table into a stand-alone variable: http://resources.esri.com/help/9.3/arcgisengine/java/gp_toolref/automating_your_work_with_models/working_with_variables.htm

  • Thanks Matte, integrating the iteration and field calcs into another model within seemed to do the trick. – Dom B Sep 12 '16 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.