4

I am trying to clip a raster layer. I am getting the error..

ERROR 6: GDALDriver::Create() ... no create method implemented for this format.

The documentation (link below) says to use GeoTIFF (gtiff). The format GeoTIFF exists, but the extensions are .tif .tiff .TIF & .TIFF.

What am I missing?

gdal.org/gdal_translate

Edit: Raster > Extraction > Clipper... Select a region. Give it a name. Hit OK. Note the tiff file types available.

enter image description here

enter image description here

enter image description here

  • It feels like something else is happening. GeoTIFF driver for sure supports create method but GDAL seems to think that some other driver is requested. Can you give more details about your workflow? – user30184 Sep 13 '16 at 17:19
  • Can you provide full command line or steps in QGIS to reproduce? – Dmitry Baryshnikov Sep 13 '16 at 17:58
  • 1
    If you look at your 1st screenshot, the -of AIG argument in the gdal_translate command line shows the output format has been specified as ESRI ArcInfo Binary GRID. This driver does not have a create method, it's read-only. – user2856 Sep 14 '16 at 3:51
  • I can't reproduce in QGIS 2.16. But I'm running it on Linux, not Windows. The only way I can get AIG as the output format is to manually edit the gdal_translate command line in the clipper dialog. – user2856 Sep 14 '16 at 4:00
  • I am having the same issue however my command line does not have the -aig. See attached screenshot. ![enter image description here](i.stack.imgur.com/gpsRml.jpg) – Elias Moreno Aug 2 '17 at 20:18
2

The command line in your first screen shot contains -of AIG. This flag overrides the .tif extension of the output filename.

According to http://www.gdal.org/frmt_various.html#AIG, this format is read-only.

You might have run into a bug when the file type in the file dialogue does not fit to the filename, or does not get updated correctly. Since you want a Geotiff file, explicitely choose the .tif format, and check if the flag has been corrected in the command line box. By clicking on the pencil next to it, you can change it to edit mode, and change the output format identifier manually.

I can't reproduce your error here, but it might just be a stored preset from another task you did before. https://hub.qgis.org/issues/15285 seems to be a similar case.

  • Yes, that was it. And it actually insisted I specify the GTiff as the format. Thanks. – topofsteel Sep 14 '16 at 11:48
1

I had the same situation. I opened the clip raster by extent in processing tool box. I entered the input raster data and manually entered the extent. I specified the parameters like no data value, output type (byte: in my case) and compression (LZW) and it worked for me.

-1

I had your same problem and I have solved just saving the clip in a different folder of the main raster file.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Welcome to GIS SE! As a new user please take the tour to learn about our focused Question and Answer format. Please edit your answer to include more detail about how you solved the issue - some steps to replicate your solution. – Midavalo Jan 12 '17 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.