Yesterday everything was working fine, but since today I can't start Qgis anymore, because it crashes.

This affects all the versions that I have currently installed (2.8, 2.10. 2.12 and 2.14). The program loads and when it says "Starting Python", it crashes and writes a minidump (see screenshot below). QGis Browser launches normally.

What did I do yesterday: I used Grass (v.clean) and changed/cleared the folder paths for the plugin as explained in the answer to this question. Also I tried out something with a function in field calculator. But can all this cause all installed versions to crash at startup?

What could be causing this? Is there a way to manually fix this? I also tried a restart, but this didn't work. Edit: I use Windows 7 64-bit.

enter image description here

  • 4
    Run the OSGeo4W Shell program and type in qgis --noplugins. See if QGIS loads. It could be that the Processing plugin is the fault. – Joseph Sep 15 '16 at 9:01
  • I executed the OSGeo4W Shell programm from my Qgis 2.14 folder, but trying to execute the code 'qgis --noplugins' it states that the command "qgis" is wrong or not existing. I also tried to execute the command in the bin folder, but it didn't work. Additionally I tried to execute qgis-ltr-bin with '--noplugins', but then came an error message that qgis_app.dll is missing on my computer. – SnoopyTheCat Sep 15 '16 at 9:19
  • Try deleting the processing folder in C:/Users/You/.qgis2/python/plugins/processing. Personally, I would just reinstall QGIS or install the latest 2.16 version =) – Joseph Sep 15 '16 at 9:27
  • Deleting the processing folder didn't help either :( A bit confusing is for me that it affects all the versions I have currently installed. So Re-installing the latest version or 2.14 might not solve the issue? – SnoopyTheCat Sep 15 '16 at 10:57
  • 1
    @Joseph I wouldn't just blame Processing without any in-depth-knowledge of what's going on ;) – Matthias Kuhn Sep 15 '16 at 11:16

Okay, I found the solution.

The problem were Python expressions that I created yesterday to test something. I deleted them in the folder: C:\Users\xxx.qgis2\python\expressions

Now it works all fine again.

Maybe the expressions were wrong or something, kind of annoying though that it then kind of "destroys" the whole program even older versions of it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.