2

When trying to use ogr2ogr to convert to ESRI Shapefile format, I get the following error consistently across different files:

ERROR 1: Error in psSHP->sHooks.FSeek() while writing object to .shp file.

The error shows both from command line (calling the program both through OSGeo4W shell and directly) and QGIS Save As... dialog, irrespectively of the input format (tried OpenFileGDB, GeoJSON and SpatiaLite) or the CRS. I have plenty of disk space and write access to the target folder.

I have come across some bug reports concerning this but they seemed to deal with files larger than 2 GB which is not my case (around 1 MB in GeoJSON). This bug seemed to agree with the case but was closed without conclusion. I also tried a related solution from here but to no avail (QGIS starts normally).

I am using an OSGeo4W Express Desktop Install (default setup) with QGIS 2.16.2 and GDAL 2.1.1 on Windows 7 Enterprise 64bit. I have tried to reinstall the whole bundle multiple times, deleting the leftover folder.

Any ideas how to solve it?

3
  • Like the bug you referred, without test data it is hard to do anything. You can try GDAL binaries from gisinternals, though. In any case such behavior is not normal. Ogrinfo about the GeoJSON may also reveal something.
    – user30184
    Sep 16, 2016 at 13:47
  • Are you trying to Append an existing Shapefile?
    – klewis
    Sep 16, 2016 at 14:48
  • No, I am creating a new one. The other output formats work fine (GeoJSON, SpatiaLite). Ogrinfo shows normally, recognizing a point datasource. Sep 19, 2016 at 9:36

1 Answer 1

0

The issue was most likely caused by corporate security software blocking the write of more than one file because shapefiles consist of multiple files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.