0

I downloaded from internet a shp. File containing only one contour line layer. When I was trying to generate slope analysis using “Slope” Tool, an error message “One or more dropped items were invalid and will not be added to the control” popped out and I could not proceed from this point on. I googled and approached couple of attempts:

  1. Drag dataset into “input raster”, rather the layer itself;
  2. Convert the dataset to interger data type by using “ArcToolbox / Spatial Analyst Tools / Math / Int” tool;
  3. Rasterize the polylines to raster by using “Polyline to Raster” tool;
  4. Export the shp. File to CAD and attempted to use sketchup plugin to do the slope analysis ——GIS showed the exporting is successful while the CAD file is not showing up in the output folder….
  5. …….

None of them worked ….Running out of ideas…..let me know if this explains my question clearly and if you guys know where could the problem be?

  • Try downloading a Digital Elevation Model (DEM) in raster format instead of contour line vectors. – user2856 Sep 20 '16 at 1:29
2

I think your problem is relatively easy to resolve. Because the Slope tool expects a raster dataset as an input and you are introducing a vector data, it complains. In fact you are on the right track: you need to convert your contour lines into a (seamless) raster but you need to fill in the gaps in between these contours by somewhat meaningful values, which is called interpolation. Please try Topo to Raster tool to create a simple digital elevation model (DEM) and use this raster as the input to Slope tool.

  • Thank you very much for your response. I tried Topo to Raster, but it failed. I got an error message : – XCheng Sep 20 '16 at 15:04
  • The error message is: Output surface raster:,empty>, Output stream polyline features: <empty>,.......things like that. any clue? – XCheng Sep 20 '16 at 15:05
  • The error code is : 010277: too many points in the contour polyline.... – XCheng Sep 20 '16 at 15:07
1

Have you tried using the contour lines to create a TIN, and then export the TIN to raster? That worked for me a while ago.

If the tool is giving the error message about too many points, you may want to use the "Simplify Tool" to decrease the number of vertices in the line features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.